Bug 728616 - internal SD cardreader not working
Summary: internal SD cardreader not working
Keywords:
Status: CLOSED DUPLICATE of bug 722509
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 20:09 UTC by Jon VanAlten
Modified: 2015-07-13 04:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 20:06:04 UTC


Attachments (Terms of Use)

Description Jon VanAlten 2011-08-05 20:09:09 UTC
Description of problem:
When a SDHC card (which works fine on other systems) is inserted, it is not mounted at all.  dmesg provides a bunch of output (here is a snippet):

[  782.874127] end_request: I/O error, dev mmcblk0, sector 0
[  782.874212] mmcblk0: error -110 sending status command
[  782.874217] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x0
[  782.874223] end_request: I/O error, dev mmcblk0, sector 1
[  782.874309] mmcblk0: error -110 sending status command
[  782.874315] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x0
[  782.874347] end_request: I/O error, dev mmcblk0, sector 2
[  782.874443] mmcblk0: error -110 sending status command
[  782.874450] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x0

And more of the same.  This is on Thinkpad X220, but the offending hardware appears in a handful of other laptops.

$ lspci 
<SNIP>
0d:00.0 System peripheral: Ricoh Co Ltd Device e823 (rev 07)
....

Version-Release number of selected component (if applicable):

kernel-2.6.40-4.fc15.x86_64
(This was also happening on 2.6.38 before I updated)

How reproducible:
Insert SD card into internal cardreader.
  
Actual results:
Bunch of dmesg errors and no device turns up.

Expected results:
card filesystems mounted, or device accessible at least somehow.

Additional info:

When I was trying to figure out what was happening, I discovered that this has been reported (and fixed!!! happytime!!) at ubuntu:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/773524

I can confirm that the workaround in the comments works for me.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/773524/comments/13


I haven't gone so far as looking at (much less trying to build) the actual fix.

Comment 1 Dave Jones 2011-08-06 03:52:43 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=257107 should fix this.

Comment 2 Jon VanAlten 2011-08-07 21:44:38 UTC
No change here.

$ uname -r
2.6.40.1-0.fc15.x86_64

(but the workaround still works)

Let me know if I can try any other builds, or provide any other information.

Comment 3 Dave Jones 2011-08-17 21:10:11 UTC
how about 2.6.40.3 ?

Comment 4 Jon VanAlten 2011-08-18 16:25:38 UTC
Still no dice.

Comment 5 Sergey Popov 2011-09-05 19:06:50 UTC
I have same problem
After update kernel from RFRemix (2.6.38.8-35.fc15.i686.PAE) to RFRemix (2.6.40-4.fc15.i686.PAE) MMC card not work in internal cardreader on Fujitstu Lifebook E780, but SD card work perfectly.When I booting whith old kernel all work. After update to (2.6.40.3-0.fc15.i686.PAE) MMC not work too.

dmesg on SD card
/var/log/message:
[ 1646.819824] mmc0: new high speed SD card at address b368
[ 1646.887901] mmcblk0: mmc0:b368 SD    1.90 GiB 
[ 1646.906684]  mmcblk0: p1

dmesg on MMC card
Aug 20 11:05:27 KesinBook kernel: [ 1789.919189] mmc0: error -110 whilst initialising MMC card
Aug 20 11:05:27 KesinBook kernel: [ 1790.007110] mmc0: error -110 whilst initialising MMC card
Aug 20 11:05:27 KesinBook kernel: [ 1790.091590] mmc0: new MMC card at address 0001
Aug 20 11:05:27 KesinBook kernel: [ 1790.092096] mmcblk0: mmc0:0001 000000 30.6 MiB 
Aug 20 11:05:27 KesinBook kernel: [ 1790.095031]  mmcblk0: p1
Aug 20 11:05:27 KesinBook kernel: [ 1790.111112] mmc0: Got data interrupt 0x00200000 even though no data operation was in progress.
Aug 20 11:05:27 KesinBook kernel: [ 1790.111236] mmcblk0: retrying using single block read
Aug 20 11:05:27 KesinBook kernel: [ 1790.113428] mmc0: Got data interrupt 0x00200000 even though no data operation was in progress.
Aug 20 11:05:27 KesinBook kernel: [ 1790.114238] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x400b00
Aug 20 11:05:27 KesinBook kernel: [ 1790.114247] end_request: I/O error, dev mmcblk0, sector 62592
Aug 20 11:05:27 KesinBook kernel: [ 1790.116675] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x400b00
Aug 20 11:05:27 KesinBook kernel: [ 1790.116684] end_request: I/O error, dev mmcblk0, sector 62593
Aug 20 11:05:27 KesinBook kernel: [ 1790.119022] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x400b00
Aug 20 11:05:27 KesinBook kernel: [ 1790.119029] end_request: I/O error, dev mmcblk0, sector 62594
Aug 20 11:05:27 KesinBook kernel: [ 1790.121382] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x400b00
Aug 20 11:05:27 KesinBook kernel: [ 1790.121389] end_request: I/O error, dev mmcblk0, sector 62595
Aug 20 11:05:27 KesinBook kernel: [ 1790.123670] mmcblk0: error -110 sending read/write command, response 0x0, card status 0x400b00

Comment 6 Josh Boyer 2011-10-04 20:06:04 UTC

*** This bug has been marked as a duplicate of bug 722509 ***


Note You need to log in before you can comment on or make changes to this bug.