Bug 728623 - iwhd damages its argv
Summary: iwhd damages its argv
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iwhd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jim Meyering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 20:41 UTC by Pete Zaitcev
Modified: 2016-04-27 04:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-19 05:15:56 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2011-08-05 20:41:43 UTC
Description of problem:

If a sysadmin runs "ps auxw| grep iwhd" in Aeolus configuration, he sees:
root  3000  1  1 12:06 ?  00:05:03 iwhd -c /etc/iwhd/conf.js -d localhost 27017
This is deceptive in that he cannot copy-paste the arguments into
the /etc/sysconfig/iwhd. A courtegeous program should retain the colon
in localhost:27017.

Version-Release number of selected component (if applicable):

0.97

How reproducible:

Synchronous

Steps to Reproduce:
1. Install Aeolus (so that -d is used)
2. ps auxw| grep iwhd
  
Actual results:

-d locahost 27017

Expected results:

-d localhost:27017

Additional info:

The best fix should include /etc/sysconfig/iwhd with an example,
only commented out.

Comment 1 Jim Meyering 2011-08-08 10:10:48 UTC
Thanks, Pete.
I've fixed that and a few other things (-m needed it, too)
and -p GARBAGE was not rejected.  Here's the patch:

http://thread.gmane.org/gmane.comp.lib.iwhd.devel/781

Comment 2 Pete Zaitcev 2011-08-08 18:09:27 UTC
Thank heavens we don't support service called "garbage". I always thought
that a forward lookup in /etc/services was an idiotic indirection due to port
numbers being mandated by standards and practices. But Uli disagrees.

Comment 3 Pete Zaitcev 2011-10-19 05:15:56 UTC
Fixed in 0.98.


Note You need to log in before you can comment on or make changes to this bug.