Bug 728639 - Various plotting bugs in Octave 3.4.0 are solved by upgrade to 3.4.2
Summary: Various plotting bugs in Octave 3.4.0 are solved by upgrade to 3.4.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 22:50 UTC by Mike Reid
Modified: 2011-09-05 23:33 UTC (History)
6 users (show)

Fixed In Version: octave-image-1.0.14-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-28 05:25:58 UTC


Attachments (Terms of Use)

Description Mike Reid 2011-08-05 22:50:56 UTC
Description of problem:

There are various bugs that make plots from octave unreliable. 
These appear to be fixed in the latest stable version, 3.4.2. 

Version-Release number of selected component (if applicable):

3.4.0-6.fc15 i686

How reproducible:

Completely (on 32 bit version) 

Steps to Reproduce:
$octave
x = 0.1:0.1:1;
y = 0.043 * x.^0.36;
plot(x,y);

Actual results:

Plot displays but there is an error message: 

error: memory exhausted or requested size too large for range of Octave's index type -- trying to return to prompt

Expected results:

No error message! 

Additional info:

Known bug in 3.4.0 See: 
https://savannah.gnu.org/bugs/?33947

I have compiled 3.4.2 and it works fine.

Comment 1 Susi Lehtola 2011-08-06 08:22:55 UTC
I don't have a 32-bit machine so that I could reproduce this. However, I've built 3.4.2 in rawhide. http://koji.fedoraproject.org/koji/taskinfo?taskID=3255918

Getting 3.4.2 in F15 (and F16) is going to require some amount of work, since the API version has somehow been rolled back from 47 to 45, and so all 7 packages that build against octave have to be rebuilt.

Comment 3 Mike Reid 2011-08-06 21:06:07 UTC
Thanks, but the latter link says "failed". Or am I misinterpreting it the page? 

BuildError: error building package (arch i686), mock exited with status 1; see build.log for more information

Comment 4 Fedora Update System 2011-08-12 17:36:37 UTC
octave-3.4.2-2.fc15,octave-audio-1.1.4-3.fc15,octave-control-2.0.2-3.fc15,octave-miscellaneous-1.0.11-3.fc15,octave-octcdf-1.1.2-2.fc15,octave-symbolic-1.0.9-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/octave-3.4.2-2.fc15,octave-audio-1.1.4-3.fc15,octave-control-2.0.2-3.fc15,octave-miscellaneous-1.0.11-3.fc15,octave-octcdf-1.1.2-2.fc15,octave-symbolic-1.0.9-3.fc15

Comment 5 Fedora Update System 2011-08-12 17:36:48 UTC
octave-3.4.2-2.fc16,octave-audio-1.1.4-3.fc16,octave-control-2.0.2-3.fc16,octave-miscellaneous-1.0.11-3.fc16,octave-octcdf-1.1.2-2.fc16,octave-symbolic-1.0.9-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/octave-3.4.2-2.fc16,octave-audio-1.1.4-3.fc16,octave-control-2.0.2-3.fc16,octave-miscellaneous-1.0.11-3.fc16,octave-octcdf-1.1.2-2.fc16,octave-symbolic-1.0.9-3.fc16

Comment 6 Fedora Update System 2011-08-12 17:36:58 UTC
octave-3.4.2-2.el6,octave-octcdf-1.1.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/octave-3.4.2-2.el6,octave-octcdf-1.1.2-2.el6

Comment 7 Fedora Update System 2011-08-12 18:34:06 UTC
octave-image-1.0.14-2.el6,octave-octcdf-1.1.2-2.el6,octave-3.4.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/octave-image-1.0.14-2.el6,octave-octcdf-1.1.2-2.el6,octave-3.4.2-2.el6

Comment 8 Fedora Update System 2011-08-12 20:35:41 UTC
Package octave-3.4.2-2.fc16, octave-audio-1.1.4-3.fc16, octave-control-2.0.2-3.fc16, octave-miscellaneous-1.0.11-3.fc16, octave-octcdf-1.1.2-2.fc16, octave-symbolic-1.0.9-3.fc16, octave-image-1.0.14-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing octave-3.4.2-2.fc16 octave-audio-1.1.4-3.fc16 octave-control-2.0.2-3.fc16 octave-miscellaneous-1.0.11-3.fc16 octave-octcdf-1.1.2-2.fc16 octave-symbolic-1.0.9-3.fc16 octave-image-1.0.14-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/octave-image-1.0.14-2.fc16,octave-3.4.2-2.fc16,octave-audio-1.1.4-3.fc16,octave-control-2.0.2-3.fc16,octave-miscellaneous-1.0.11-3.fc16,octave-octcdf-1.1.2-2.fc16,octave-symbolic-1.0.9-3.fc16
then log in and leave karma (feedback).

Comment 9 Mike Reid 2011-08-12 20:42:50 UTC
OK, thanks. I'll get it when I can see it in the repos.

Comment 10 Mike Reid 2011-08-15 00:00:49 UTC
OK, I installed the packages (which were fc15, not 16) which seem to work fine. I've tested it on the code that used to fail, and some other code, and it seems to be working as well as my manual installation. 

Thanks! 

Minor things: 

I get this warning from Octave: 
warning: dispatch is obsolete and will be removed from a future version of Octave; please use classes instead

and I notice that the packages
octave-quaternion.noarch  1.0.0-2.fc15               updates         
octave-specfun.i686       1.0.9-2.fc15               updates         
octave-struct.i686        1.0.9-3.fc15               updates         

have not been updated (which doesn't worry me right now) 

Mike

Comment 11 Susi Lehtola 2011-08-15 06:45:03 UTC
The warning comes from something from octave-forge?

The other packages have not been rebuilt since they do not contain any binary parts. If they aren't up-to-date, you can file bugs against the packages.

Comment 12 Mike Reid 2011-08-15 07:23:00 UTC
octave-quaternion installs OK, but 
octave-specfun, octave-struct get upset about the libraries:
-----------------
# yum install octave-specfun
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ucmirror.canterbury.ac.nz
 * rpmfusion-free: ucmirror.canterbury.ac.nz
 * rpmfusion-free-updates: ucmirror.canterbury.ac.nz
 * rpmfusion-nonfree: ucmirror.canterbury.ac.nz
 * rpmfusion-nonfree-updates: ucmirror.canterbury.ac.nz
 * updates: ucmirror.canterbury.ac.nz
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package octave-specfun.i686 0:1.0.9-2.fc15 will be installed
--> Processing Dependency: liboctinterp-3.4.0.so for package: octave-specfun-1.0.9-2.fc15.i686
--> Processing Dependency: libcruft-3.4.0.so for package: octave-specfun-1.0.9-2.fc15.i686
--> Processing Dependency: liboctave-3.4.0.so for package: octave-specfun-1.0.9-2.fc15.i686
--> Finished Dependency Resolution
Error: Package: octave-specfun-1.0.9-2.fc15.i686 (updates)
           Requires: libcruft-3.4.0.so
           Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
               libcruft-3.4.0.so
           Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
               Not found
Error: Package: octave-specfun-1.0.9-2.fc15.i686 (updates)
           Requires: liboctinterp-3.4.0.so
           Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
               liboctinterp-3.4.0.so
           Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
               Not found
Error: Package: octave-specfun-1.0.9-2.fc15.i686 (updates)
           Requires: liboctave-3.4.0.so
           Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
               liboctave-3.4.0.so
           Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
----------------
similar for octave-struct
----------------

Comment 13 Susi Lehtola 2011-08-15 09:52:39 UTC
Good catch. Those packages weren't complying to the guidelines, so they were missing some dependencies and I didn't pick them up. Fixes and rebuilds coming up soon.

Comment 14 Susi Lehtola 2011-08-16 06:57:07 UTC
Okay. I've now managed to fix and rebuild octave-{struct,specfun} against the new version and added them to the updates bunch. They should appear in the repositories in the next push to updates-testing.

Comment 15 Mike Reid 2011-08-16 07:16:28 UTC
OK, thanks. I'll test those out when they appear. 

Do you have any idea where this error message on startup comes from: 
---------------
dispatch is obsolete and will be removed from a future version of Octave; please use classes instead
---------------
I don't get this when I compile it myself, and I can't figure out where it is being called...

Comment 16 Mike Reid 2011-08-17 11:18:58 UTC
OK, I've successfully installed octave-specfun and octave-struct from updates-testing and done some minimal testing. The ODE package relies on struct, and that installs and runs, so it seems to all be working.

Comment 17 stan 2011-08-17 14:13:58 UTC
When updating to the version of octave in updates-testing, I get the following errors.

Error: Package: plplot-octave-5.9.7-7.fc15.x86_64 (@/plplot-octave-5.9.7-7.fc15.x86_64)
           Requires: liboctave-3.4.0.so()(64bit)
           Removing: 6:octave-3.4.0-6.fc15.x86_64 (@/octave-3.4.0-6.fc15.x86_64)
               liboctave-3.4.0.so()(64bit)
           Updated By: 6:octave-3.4.2-2.fc15.x86_64 (updates-testing)
               Not found
Error: Package: plplot-octave-5.9.7-7.fc15.x86_64 (@/plplot-octave-5.9.7-7.fc15.x86_64)
           Requires: liboctinterp-3.4.0.so()(64bit)
           Removing: 6:octave-3.4.0-6.fc15.x86_64 (@/octave-3.4.0-6.fc15.x86_64)
               liboctinterp-3.4.0.so()(64bit)
           Updated By: 6:octave-3.4.2-2.fc15.x86_64 (updates-testing)
               Not found

Comment 18 Mike Reid 2011-08-18 00:29:01 UTC
The package: pfstools-octave-1.8.3-1.fc15.i686 has dependency issues: 

12:21:30 : ERROR: Dependency resolving completed with errors
12:21:30 : ERROR:   Package: pfstools-octave-1.8.3-1.fc15.i686 (updates)
    Requires: libcruft-3.4.0.so
    Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
        libcruft-3.4.0.so
    Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
        Not found
12:21:30 : ERROR:   Package: pfstools-octave-1.8.3-1.fc15.i686 (updates)
    Requires: liboctave-3.4.0.so
    Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
        liboctave-3.4.0.so
    Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
        Not found
12:21:30 : ERROR:   Package: pfstools-octave-1.8.3-1.fc15.i686 (updates)
    Requires: liboctinterp-3.4.0.so
    Available: 6:octave-3.4.0-6.fc15.i686 (fedora)
        liboctinterp-3.4.0.so
    Installed: 6:octave-3.4.2-2.fc15.i686 (@updates-testing)
        Not found

Some other packages I can find: qtoctave, csdp-octave do not seem to have issues.

Comment 19 Susi Lehtola 2011-08-18 08:42:38 UTC
Again a missing dependency on octave(api). Fixed build coming up soon. That should be the last of them.

Comment 20 Mike Reid 2011-08-18 09:21:02 UTC
Thanks. I have found no other problems. I can build packages from octave-forge and have been doing various calculations with no problems.

Comment 21 Mike Reid 2011-08-22 20:46:44 UTC
Thanks again Jussi, 

I've now got all "*octave*" packages installed with no conflicts. I tried running some functions from pfstools and plplot and they didn't fall over, but I'll have to leave it to users of those packages to test them seriously. 

yum list --enablerepo=updates-testing "*octave*"
...
Installed Packages
csdp-octave.noarch                   6.1.1-1.fc15               @fedora         
octave.i686                          6:3.4.2-2.fc15             @updates-testing
octave-audio.i686                    1.1.4-3.fc15               @updates-testing
octave-control.i686                  2.0.2-3.fc15               @updates-testing
octave-devel.i686                    6:3.4.2-2.fc15             @updates-testing
octave-doc.noarch                    6:3.4.2-2.fc15             @updates-testing
octave-image.i686                    1.0.14-2.fc15              @updates-testing
octave-miscellaneous.i686            1.0.11-3.fc15              @updates-testing
octave-octcdf.i686                   1.1.2-2.fc15               @updates-testing
octave-quaternion.noarch             1.0.0-2.fc15               @updates        
octave-specfun.i686                  1.0.9-4.fc15               @updates-testing
octave-struct.i686                   1.0.9-5.fc15               @updates-testing
octave-symbolic.i686                 1.0.9-3.fc15               @updates-testing
pfstools-octave.i686                 1.8.3-2.fc15               @updates-testing
plplot-octave.i686                   5.9.7-9.fc15.2             @updates-testing
qtoctave.i686                        0.10.1-3.fc15              @fedora

Comment 22 Fedora Update System 2011-08-28 05:25:52 UTC
octave-struct-1.0.9-5.fc16, octave-specfun-1.0.9-4.fc16, plplot-5.9.8-2.fc16, pfstools-1.8.3-2.fc16, octave-3.4.2-2.fc16, octave-audio-1.1.4-3.fc16, octave-control-2.0.2-3.fc16, octave-miscellaneous-1.0.11-3.fc16, octave-octcdf-1.1.2-2.fc16, octave-symbolic-1.0.9-3.fc16, octave-image-1.0.14-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-08-31 01:34:20 UTC
octave-specfun-1.0.9-4.fc15, octave-struct-1.0.9-5.fc15, plplot-5.9.7-9.fc15.2, pfstools-1.8.3-2.fc15, octave-3.4.2-2.fc15, octave-audio-1.1.4-3.fc15, octave-control-2.0.2-3.fc15, octave-miscellaneous-1.0.11-3.fc15, octave-octcdf-1.1.2-2.fc15, octave-symbolic-1.0.9-3.fc15, octave-image-1.0.14-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2011-09-05 23:33:03 UTC
octave-image-1.0.14-2.el6, octave-octcdf-1.1.2-2.el6, octave-3.4.2-2.el6, plplot-5.9.7-3.el6.1 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.