Bug 728654 - libvirtd.conf error causes libvirtd to exit silently
Summary: libvirtd.conf error causes libvirtd to exit silently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 04:38 UTC by Dave Allan
Modified: 2016-04-26 15:19 UTC (History)
5 users (show)

Fixed In Version: libvirt-0.9.4-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: Error checks on early libvirtd startup did not report errors verbosely. Consequence: Broken configuration file or other early errors while libvirtd was starting up caused the daemon to exit silently only setting the process return value to indicate error. This confused the users, as no message was printed and the process return code has to be checked manualy. Fix: Error handling messages were added to the early start phases of libvirtd. Result: Errors during start are now printed and logged.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:23:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Dave Allan 2011-08-06 04:38:04 UTC
Starting libvirtd with a configuration file containing an unterminated string for log_outputs causes libvirtd to exit silently.

After adding the following to libvirtd.conf

log_outputs="1:file:/var/log/libvirt/libvirt_debug.log

libvirtd, even when started from the commandline with -v, exited silently; nothing in the logs, nothing on stdout to indicate what was wrong.

Comment 4 dyuan 2011-08-23 09:18:55 UTC
Verified PASS with libvirt-0.9.4-5.el6, reproduced this bug with libvirt-0.9.4.4.el6.

# service libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon: 05:10:16.742: 11484: info : libvirt version: 0.9.4, package: 5.el6 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-08-22-12:26:05, x86-009.build.bos.redhat.com)
05:10:16.742: 11484: error : main:1394 : Can't load config file '/etc/libvirt/libvirtd.conf'
                                                           [FAILED]

# libvirtd
05:10:35.896: 11488: info : libvirt version: 0.9.4, package: 5.el6 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-08-22-12:26:05, x86-009.build.bos.redhat.com)
05:10:35.896: 11488: error : main:1394 : Can't load config file '/etc/libvirt/libvirtd.conf'

Comment 5 Peter Krempa 2011-11-11 09:52:47 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
Error checks on early libvirtd startup did not report errors verbosely.

Consequence:
Broken configuration file or other early errors while libvirtd was starting up caused the daemon to exit silently only setting the process return value to indicate error.
This confused the users, as no message was printed and the process return code has to be checked manualy.

Fix:
Error handling messages were added to the early start phases of libvirtd.

Result:
Errors during start are now printed and logged.

Comment 6 errata-xmlrpc 2011-12-06 11:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.