Bug 728656 - Checksum files reject .iso image but "like" netinst.iso
Summary: Checksum files reject .iso image but "like" netinst.iso
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 05:25 UTC by George R. Goffe
Modified: 2014-03-17 03:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-04 22:16:51 UTC


Attachments (Terms of Use)

Description George R. Goffe 2011-08-06 05:25:47 UTC
Description of problem:

I have downloaded the FC 15 install iso files and the checksum file and the netinst file. Then I run sha256sum -c Fedora-15-i386-CHECKSUM and get a non-match condition for the main .iso image.

Version-Release number of selected component (if applicable):

Fedora core 15

How reproducible:

I've tried several different mirrors with the same results.

Steps to Reproduce:
1.download all 3 files
2.run sha256sum -c Fedora-15-i386-CHECKSUM
3.observe error messages.
  
Actual results:

sha256sum -c Fedora-15-i386-CHECKSUM 
Fedora-15-i386-DVD.iso: FAILED
Fedora-15-i386-netinst.iso: OK
sha256sum: WARNING: 20 lines are improperly formatted
sha256sum: WARNING: 1 computed checksum did NOT match
clipper bash-4.1 /export/home/isos# l
total 3765576
drwxr-xr-x  2 root root       4096 Aug  4 22:03 .
drwxr-xr-x 16 root root       4096 Aug  3 22:10 ..
-rw-r--r--  1 root root       1112 May 24 14:22 Fedora-15-i386-CHECKSUM
-rw-r--r--  1 root root 3650455552 May 13 12:59 Fedora-15-i386-DVD.iso
-rw-r--r--  1 root root  205471744 May 13 12:58 Fedora-15-i386-netinst.iso



Expected results:

OK for the Fedora-15-i386-DVD.iso file.

Additional info:

Current system is FC 14; up to date.

Comment 1 Andre Robatino 2011-08-07 08:26:30 UTC
The sizes and timestamps on your 3 files look correct. Suggest running rsync on Fedora-15-i386-DVD.iso to try repairing it. In the same directory, run

touch Fedora-15-i386-DVD.iso (so rsync doesn't just assume the file is correct since the timestamps match)

rsync -avzP dl.fedoraproject.org::fedora-linux-releases/15/Fedora/i386/iso/Fedora-15-i386-DVD.iso . (note the trailing .)

I had an existing copy of the i386 F15 DVD ISO and verified that the version of the file I rsync'ed using the above commands matched the checksum.

Comment 2 Andre Robatino 2011-08-07 08:30:53 UTC
If you still can't match the checksum after trying the above, look into hardware problems at your end - for example, try running memtest. This is more likely especially since you say you experienced it on several different mirrors. Although it can happen, the chances of it happening on more than one attempted mirror is pretty low.

Comment 3 Bill Nottingham 2012-01-04 22:16:51 UTC
Closing... no response in a few months.

Comment 4 George R. Goffe 2012-01-05 00:01:47 UTC
Bill,

Thanks for closing this ticket.

I will add making more timely updates to "my" tickets to my new years resolutions.

HAPPY NEW YEAR!

Regards,

George...


Note You need to log in before you can comment on or make changes to this bug.