Bug 728657 - File conflicts in Fedora 16 Alpha RC1: kdesdk (kdesdk-libs not correctly obsoleted?)
File conflicts in Fedora 16 Alpha RC1: kdesdk (kdesdk-libs not correctly obso...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-08-06 02:07 EDT by Andre Robatino
Modified: 2011-08-15 13:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 13:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-08-06 02:07:25 EDT
Description of problem:

https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts

On i386:

Getting complete filelist for:
file:///media/
383187 files found.

Looking for duplicated filenames:
223 duplicates found.

Doing more advanced checks to see if these are real conflicts:
  5% complete (    11/   223,    83/sec),    0 found - eta 0:00:02
 10% complete (    22/   223,    74/sec),    1 found - eta 0:00:02
 15% complete (    33/   223,   557/sec),    1 found - eta 0:00:01
 20% complete (    44/   223,   749/sec),    1 found - eta 0:00:01
 25% complete (    55/   223,   293/sec),    1 found - eta 0:00:01
 30% complete (    66/   223,   317/sec),    3 found - eta 0:00:00
 35% complete (    77/   223,   179/sec),    4 found - eta 0:00:00
 39% complete (    88/   223, 19683/sec),    4 found - eta 0:00:00
 44% complete (    99/   223,  1491/sec),    5 found - eta 0:00:00
 49% complete (   110/   223,  1191/sec),    6 found - eta 0:00:00
 54% complete (   121/   223,   351/sec),    8 found - eta 0:00:00
 59% complete (   132/   223,   490/sec),    9 found - eta 0:00:00
 64% complete (   143/   223,   478/sec),   10 found - eta 0:00:00
 69% complete (   154/   223,   454/sec),   13 found - eta 0:00:00
 74% complete (   165/   223,   498/sec),   14 found - eta 0:00:00
 79% complete (   176/   223,  1657/sec),   15 found - eta 0:00:00
 84% complete (   187/   223,   646/sec),   16 found - eta 0:00:00
 89% complete (   198/   223,   305/sec),   16 found - eta 0:00:00
 94% complete (   209/   223,   334/sec),   18 found - eta 0:00:00
 99% complete (   220/   223,   576/sec),   19 found - eta 0:00:00
19 file conflicts found.
1 package conflicts found.

== Package conflicts ==
kate-libs-4.7.0-2.fc16.i686
kdesdk-libs-4.6.95-1.fc16.i686


== File conflicts, listed by conflicting packages ==
libreport-python-2.0.5-2.fc16.i686
report-newt-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/NewtIO.py
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyc
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyo

kdesdk-kompare-libs-4.7.0-2.fc16.i686
kdesdk-libs-4.6.95-1.fc16.i686
  /usr/lib/libkomparedialogpages.so.4.7.0
  /usr/lib/libkomparediff2.so.4.7.0
  /usr/lib/libkompareinterface.so.4.7.0

kdesdk-libs-4.6.95-1.fc16.i686
kdesdk-okteta-libs-4.7.0-2.fc16.i686
  /usr/lib/kde4/plugins/designer/oktetadesignerplugin.so
  /usr/lib/libkastencontrollers.so.4.7.0
  /usr/lib/libkastencore.so.4.7.0
  /usr/lib/libkastengui.so.4.7.0
  /usr/lib/liboktetacore.so.4.7.0
  /usr/lib/liboktetagui.so.4.7.0
  /usr/lib/liboktetakastencontrollers.so.4.7.0
  /usr/lib/liboktetakastencore.so.4.7.0
  /usr/lib/liboktetakastengui.so.4.7.0

kdesdk-kmtrace-libs-4.7.0-2.fc16.i686
kdesdk-libs-4.6.95-1.fc16.i686
  /usr/lib/libktrace.so.4.7.0

libreport-python-2.0.5-2.fc16.i686
report-gtk-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/GTKIO.py
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyc
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyo

On x86_64:

Getting complete filelist for:
file:///media/
383065 files found.

Looking for duplicated filenames:
229 duplicates found.

Doing more advanced checks to see if these are real conflicts:
  5% complete (    11/   229,   233/sec),    0 found - eta 0:00:00
 10% complete (    22/   229,   370/sec),    1 found - eta 0:00:00
 14% complete (    33/   229,   178/sec),    2 found - eta 0:00:00
 19% complete (    44/   229,  1419/sec),    2 found - eta 0:00:00
 24% complete (    55/   229,   470/sec),    2 found - eta 0:00:00
 29% complete (    66/   229,  1035/sec),    3 found - eta 0:00:00
 34% complete (    77/   229,   476/sec),    6 found - eta 0:00:00
 38% complete (    88/   229,   600/sec),    9 found - eta 0:00:00
 43% complete (    99/   229, 12657/sec),    9 found - eta 0:00:00
 48% complete (   110/   229, 17602/sec),    9 found - eta 0:00:00
 53% complete (   121/   229,   676/sec),   10 found - eta 0:00:00
 58% complete (   132/   229,  2413/sec),   10 found - eta 0:00:00
 62% complete (   143/   229,   788/sec),   10 found - eta 0:00:00
 67% complete (   154/   229,   669/sec),   11 found - eta 0:00:00
 72% complete (   165/   229,   928/sec),   11 found - eta 0:00:00
 77% complete (   176/   229,  1410/sec),   12 found - eta 0:00:00
 82% complete (   187/   229,   200/sec),   13 found - eta 0:00:00
 86% complete (   198/   229,   301/sec),   15 found - eta 0:00:00
 91% complete (   209/   229,  1929/sec),   16 found - eta 0:00:00
 96% complete (   220/   229,   592/sec),   18 found - eta 0:00:00
19 file conflicts found.
1 package conflicts found.

== Package conflicts ==
kate-libs-4.7.0-2.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64


== File conflicts, listed by conflicting packages ==
libreport-python-2.0.5-2.fc16.x86_64
report-gtk-0.23-0.fc16.x86_64
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.py
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.pyc
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.pyo

kdesdk-kompare-libs-4.7.0-2.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64
  /usr/lib64/libkomparedialogpages.so.4.7.0
  /usr/lib64/libkomparediff2.so.4.7.0
  /usr/lib64/libkompareinterface.so.4.7.0

libreport-python-2.0.5-2.fc16.x86_64
report-newt-0.23-0.fc16.x86_64
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.py
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.pyc
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.pyo

kdesdk-kmtrace-libs-4.7.0-2.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64
  /usr/lib64/libktrace.so.4.7.0

kdesdk-libs-4.6.95-1.fc16.x86_64
kdesdk-okteta-libs-4.7.0-2.fc16.x86_64
  /usr/lib64/kde4/plugins/designer/oktetadesignerplugin.so
  /usr/lib64/libkastencontrollers.so.4.7.0
  /usr/lib64/libkastencore.so.4.7.0
  /usr/lib64/libkastengui.so.4.7.0
  /usr/lib64/liboktetacore.so.4.7.0
  /usr/lib64/liboktetagui.so.4.7.0
  /usr/lib64/liboktetakastencontrollers.so.4.7.0
  /usr/lib64/liboktetakastencore.so.4.7.0
  /usr/lib64/liboktetakastengui.so.4.7.0

Version-Release number of selected component (if applicable):
16-Alpha.RC1
Comment 1 Adam Williamson 2011-08-06 11:20:12 EDT
on the kdesdk thing: I think the latest kdesdk has no -libs subpackage, but it's getting pulled in either through comps or a manual dependency...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Tim Flink 2011-08-08 12:38:12 EDT
Discussed in the 2011-08-08 Fedora QA meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install 

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 3 Adam Williamson 2011-08-08 15:09:38 EDT
Let's split this out into two bugs. Andre, in future, can you file separate bugs for each obviously different group of conflicting packages, and assign each to an appropriate maintainer, when running this test? A single bug for multiple conflicts involving multiple unrelated packages is tough to manage.

Let's make this bug for the KDE issue, so this bug now concerns only:

kdesdk-kompare-libs-4.7.0-2.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64
  /usr/lib64/libkomparedialogpages.so.4.7.0
  /usr/lib64/libkomparediff2.so.4.7.0
  /usr/lib64/libkompareinterface.so.4.7.0

kdesdk-kmtrace-libs-4.7.0-2.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64
  /usr/lib64/libktrace.so.4.7.0

kdesdk-libs-4.6.95-1.fc16.x86_64
kdesdk-okteta-libs-4.7.0-2.fc16.x86_64
  /usr/lib64/kde4/plugins/designer/oktetadesignerplugin.so
  /usr/lib64/libkastencontrollers.so.4.7.0
  /usr/lib64/libkastencore.so.4.7.0
  /usr/lib64/libkastengui.so.4.7.0
  /usr/lib64/liboktetacore.so.4.7.0
  /usr/lib64/liboktetagui.so.4.7.0
  /usr/lib64/liboktetakastencontrollers.so.4.7.0
  /usr/lib64/liboktetakastencore.so.4.7.0
  /usr/lib64/liboktetakastengui.so.4.7.0

Re-assigning to kdesdk. I believe the cause is as I noted in comment #1.
Comment 4 Rex Dieter 2011-08-08 15:18:15 EDT
Odd, kdesdk.spec already includes

# when split occurred
Obsoletes: kdesdk-libs < 4.6.95-10

in the main pkg, I'll do some repoqueries to see if anything is explicitly trying to pull in kdesdk-libs for some reason.
Comment 5 Adam Williamson 2011-08-08 15:19:22 EDT
I note that kdesdk-4.7.0-2.fc16.x86_64 does have:

Obsoletes:	kdesdk-libs < 4.6.95-10

so I'm not entirely sure why kdesdk-libs-4.6.95-1 is getting pulled into the compose. Dennis may be able to shed some light.

As far as I can see, everything kdesdk-libs-4.6.95-1.fc16 provided - see http://koji.fedoraproject.org/koji/rpminfo?rpmID=2610241 - is provided by some subpackage or other of kdelibs-4.7.0-2.fc16, so it must be something more indirect.

The three 4.6.95-1 packages on the RC1 DVD are:

./Packages/kdesdk-4.6.95-1.fc16.x86_64.rpm
./Packages/kdesdk-libs-4.6.95-1.fc16.x86_64.rpm
./Packages/kdesdk-utils-4.6.95-1.fc16.x86_64.rpm

so it may be something in kdesdk-utils, I guess.
Comment 6 Adam Williamson 2011-08-08 15:54:05 EDT
Nope, doesn't look like that. kdesdk-utils doesn't appear to provide anything and is properly obsoleted by a subpackage of the newer kdesdk build. So I can't see anything really wrong on the package side here. It would help if Dennis could check the compose logs and see if he can figure out why the old kdesdk build got pulled in.

I suspect if we compose RC2 in an environment where the old kdesdk package isn't available at all, it'll work fine, but it's hard to be sure.
Comment 7 Kevin Kofler 2011-08-08 16:40:32 EDT
CCing one of my e-mail addresses is going to be enough. ;-)
Comment 8 Kevin Kofler 2011-08-08 17:15:49 EDT
There should really be no kdesdk-4.6.95 packages in the compose, I don't know either why the obsolete stuff gets dragged in.
Comment 9 Adam Williamson 2011-08-08 18:19:12 EDT
sorry, wasn't sure if that was you =)

yeah, I think our approach for this is simply going to be to fire off the rc2 compose and see what happens; it should happen in an environment where the older kdesdk package isn't available at all, so it'll either work and resolve this, or fail in a way that'll tell us what's missing from the newer one.
Comment 10 James Laska 2011-08-09 10:24:27 EDT
Robatino confirmed this is fixed in RC2 (https://fedoraproject.org/wiki/Test_Results:Fedora_16_Alpha_RC2_Install#DVD).  I've also re-run the conflicts [1] and deps [2] tests against i686 and x86_64 DVD media, and confirmed the problem is resolved.

  0 file conflicts found.
  0 package conflicts found.

While kdesdk is included in the DVD ISO, it seems to be only a single version (4.7.0-2).  The kdesdk-4.6.95-1 package is not on the ISO DVD media.

[1] https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts
[2] https://fedoraproject.org/wiki/QA:Testcase_Mediakit_Repoclosure
Comment 11 Adam Williamson 2011-08-15 13:25:16 EDT
RC2 and RC3 were okay, so we should be able to close this.

Note You need to log in before you can comment on or make changes to this bug.