Bug 728689 - pm: Lenovo x121e hangs during hibernate
pm: Lenovo x121e hangs during hibernate
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-08-06 08:28 EDT by Stefan Assmann
Modified: 2013-01-10 03:21 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 12:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pm-utils-bugreport-info.txt (7.05 KB, text/plain)
2011-08-06 08:39 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2011-08-06 08:28:59 EDT
Description of problem:
Lenovo x121e does not hibernate properly with "platform" in /sys/power/disk. Changing to "shutdown" and the system hibernates properly.
This is the final output after the system hangs:
ACPI handle has no context!
PM: freeze of devices complete after 1570.549 msecs
PM: late freeze of devices complete after 0.684 msecs
ACPI: Preparing to enter system sleep state S4
PM: Saving platform NVS memory
Disabling non-boot CPUs
Broke affinity for irq 17
CPU 1 is now offline
PM: Creating hibernation image:
PM: Need to copy 248412 page
PM: Normat pages needed: 248412 + 1024, available pages: 1744310
PM: Hibernation image created
Enabling non-boot CPUs
Booting Node 0 Processor 1 APIC 0x1
smpboot cpu 1: start_ip = 98000
Switched to NOHz mode on CPU #1
CPU1 is up
ACPI: Waking up from system sleep state S4

Version-Release number of selected component (if applicable):
2.6.40-4.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. pm-hibernate
2.
3.
  
Actual results:
freeze during hibernate
Comment 1 Stefan Assmann 2011-08-06 08:39:44 EDT
Created attachment 516988 [details]
pm-utils-bugreport-info.txt
Comment 2 Stefan Assmann 2011-08-06 08:47:43 EDT
Pressing the power button to hibernate fails as well. I'm not sure what exactly is invoked by that but the display simply goes black and the system never hibernates.
Comment 3 Matthew Garrett 2011-08-10 16:11:47 EDT
Can you reproduce without the catalyst driver?
Comment 4 Stefan Assmann 2011-08-11 02:24:07 EDT
yes it's exactly the same there. Originally I tried with the radeon driver, but it just turns off the screen completely so I couldn't see the console output.
Comment 5 Mario Heininger 2011-10-12 11:10:53 EDT
It seems that this depends on the WLAN Card, i will do some more test.

This thread looks like the x121 with the AMD-350 CPU and AMD Chipset, is there someone how can test this on an intel core i3 x121e ?
Comment 6 Stefan Assmann 2011-10-13 03:20:55 EDT
Mario,
interesting, what makes you think it's the WLAN card?
Btw you're right I have the AMD one. I already tried to swap the WLAN miniPCIe for an Intel ABG PRO Wireless but the system did not recognize it. I assume the BIOS carries a whitelist of PCI IDs, which is a pain.
Comment 7 Mario Heininger 2011-10-13 05:38:39 EDT
Stefan, you are so right. After some tests, it does not depend on the wlan card. And well, the same problem is still exist in F16 Beta.

I can't seen anything in the logs for this issue ...
Comment 8 Mario Heininger 2011-10-14 04:56:44 EDT
I have done some additional tests with some combinations of Fedora Releases and Kernels. 
Fedora 14 x86_64 with latest Kernel does hibernate correctly but F14 has no driver for the internal Ethernet an the WLAN Card.

On F15 and F16 x86_x64 with all Kernels the Hibernation doesn't work. At last i have tried to disable the Ethernet, Bluetooth and WLAN cards.  unloaded all Drivers for theses cards, but this doesn't help.
Comment 9 Stefan Assmann 2011-10-14 05:26:13 EDT
Reading your comment I just tried to hibernate on F16 with the latest F14 kernel and that fails for me. Still seeing a black screen only and waiting forever.
Tried both running pm-hibernate manually and hibernate via gnome menu.
Comment 10 Mario Heininger 2011-11-09 02:14:05 EST
So after a much testing, i have no idea where the Problem is. F14 was the last working Fedora Release but without networking. Testing in F16 is a little bit strange, because the xfce4-power-manager is also not working on the x121e, while it works on the Thinkpad T410.
Comment 11 David Robinson 2011-11-13 11:45:47 EST
I have a Lenovo x100e that does not wish to hibernate or suspend under F16 (x86_64). Both features worked fine for me under F15. I get the same results as Comment 9, in that the screen goes black and the notebook remains powered on. System does not respond to keyboard or mouse inputs. I have to hold down the power button to switch off. If you require log files, configuration details, hardware details etc, I will gladly provide them.
Comment 12 Josh Boyer 2012-03-28 14:02:16 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.