Bug 728694 - Swami segfaults on startup on Fedora 15 x86_64
Summary: Swami segfaults on startup on Fedora 15 x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: swami
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 13:10 UTC by fropeter
Modified: 2011-08-31 01:21 UTC (History)
2 users (show)

Fixed In Version: swami-2.0.0-1.20110806svn386.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 20:39:17 UTC


Attachments (Terms of Use)

Description fropeter 2011-08-06 13:10:53 UTC
Description of problem:
When I start Swami by clicking it's icon or from cli, a message box pops up with the text:

  Application "swami" (process [pid]) has crashed due to a fatal error. 
  (Memory segmentation error)

Version-Release number of selected component (if applicable):
swami-0.9.4-7.fc15 (x86_64)

How reproducible:
Every time

Steps to Reproduce:
1.Start swami from terminal or gnome gui
2.swami crashes
3.
  
Actual results:
swami crashes

Expected results:
swami should start 

Additional info:

I have found a Ubuntu bug report that might have the patch that fixes this, apparently from the author, but this patch is not applied upstream as of today.

https://bugs.launchpad.net/ubuntu/+source/swami/+bug/810569

The fix seems to be trivial; it is a swap of two parameters in a qsort function call. 

When starting swami in a terminal I also get this output before the crash:

[username@host ~]$ swami

** WARNING **: Failed to open config file "/home/username/.swami/swami.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/swami_state.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/plugins.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/plugin_state.cfg": Ingen slik fil eller filkatalog
Message: Loading plugins from /usr/lib64/swami
Message: Loading plugin "/usr/lib64/swami/samplelib_libsndfile.so"...
Message: Plugin "/usr/lib64/swami/samplelib_libsndfile.so" loaded
Message: Loading plugin "/usr/lib64/swami/wavetbl_fluidsynth.so"...
Message: Plugin "/usr/lib64/swami/wavetbl_fluidsynth.so" loaded
Message: Loading plugin "/usr/lib64/swami/samplelib_audiofile.so"...
Message: Plugin "/usr/lib64/swami/samplelib_audiofile.so" loaded
Message: Loaded 3 plugins
[username@host ~]$

Please guide me if you need more info.

Comment 1 fropeter 2011-08-06 13:47:26 UTC
I installed the swami-debuginfo-0.9.4-7.fc15 (x86_64) package and ran swami from the terminal with these options
swami -d --disable-crash-dialog

resulting in the following output in the terminal:

** WARNING **: Failed to open config file "/home/username/.swami/swami.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/swami_state.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/plugins.cfg": Ingen slik fil eller filkatalog

** WARNING **: Failed to open config file "/home/username/.swami/plugin_state.cfg": Ingen slik fil eller filkatalog

Gtk-WARNING **: invalid cast from (NULL) pointer to `SwamiWavetbl'

Gtk-WARNING **: invalid cast from (NULL) pointer to `SwamiMidi'

-----------
At this point the swami gui started up, however when I closed the gui, the following was output in the terminal:

Minnesegmentsfeil (core dumped)
(Translates to memory segmentation fault)

ABRT reported
Process /usr/bin/swami was killed by signal 11 (SIGSEGV)

If you need the abrt report, how do I attach it to this report?

BTW, if the swami internal crash dialog prevents abrt from detecting the crash, maybe the standard startup should include the parameter
 "--disable-crash-dialog" ?

Comment 2 Orcan Ogetbil 2011-08-06 18:13:31 UTC
Thanks for the report. The Ubuntu bug seems to be filed against swami2. Your crash is in swami1 and it is not related. It looks like some gtk1 issue, but I am not sure. 

It looks like we should probably update swami to swami2 in Fedora, as we will probably not get upstream support for swami1 anymore. Let me look into this.

Comment 3 Fedora Update System 2011-08-13 03:43:29 UTC
swami-2.0.0-1.20110806svn386.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/swami-2.0.0-1.20110806svn386.fc16

Comment 4 Fedora Update System 2011-08-13 03:45:25 UTC
swami-2.0.0-1.20110806svn386.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/swami-2.0.0-1.20110806svn386.fc15

Comment 5 Fedora Update System 2011-08-15 20:24:15 UTC
Package swami-2.0.0-1.20110806svn386.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing swami-2.0.0-1.20110806svn386.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/swami-2.0.0-1.20110806svn386.fc16
then log in and leave karma (feedback).

Comment 6 Orcan Ogetbil 2011-08-20 02:41:54 UTC
Hi, could you check the new swami update and see if it works?

  # yum --enablerepo updates-testing update swami

Comment 7 fropeter 2011-08-20 14:27:15 UTC
It works perfectly on Fedora 15. Thank you!

Comment 8 Fedora Update System 2011-08-30 20:39:12 UTC
swami-2.0.0-1.20110806svn386.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-08-31 01:21:53 UTC
swami-2.0.0-1.20110806svn386.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.