Bug 728731 - SELinux is preventing /usr/libexec/colord from using the 'execstack' accesses on a process.
Summary: SELinux is preventing /usr/libexec/colord from using the 'execstack' accesses...
Keywords:
Status: CLOSED DUPLICATE of bug 741086
Alias: None
Product: Fedora
Classification: Fedora
Component: colord
Version: rawhide
Hardware: i386
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d1f911cbe52...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 18:43 UTC by Jim
Modified: 2011-12-03 21:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-15 12:11:41 UTC


Attachments (Terms of Use)

Description Jim 2011-08-06 18:43:04 UTC
SELinux is preventing /usr/libexec/colord from using the 'execstack' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that colord should be allowed execstack access on processes labeled colord_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Objects                Unknown [ process ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           colord-0.1.7-1.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.i686 #1 SMP Fri Jul
                              29 18:54:39 UTC 2011 i686 i686
Alert Count                   1
First Seen                    Sat 06 Aug 2011 10:38:30 AM EDT
Last Seen                     Sat 06 Aug 2011 10:38:30 AM EDT
Local ID                      526bb5d2-7d68-4c53-8d41-cf44e879b5a0

Raw Audit Messages
type=AVC msg=audit(1312641510.641:19): avc:  denied  { execstack } for  pid=1070 comm="colord" scontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tcontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tclass=process


type=AVC msg=audit(1312641510.641:19): avc:  denied  { execmem } for  pid=1070 comm="colord" scontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tcontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1312641510.641:19): arch=i386 syscall=mprotect success=yes exit=0 a0=bff18000 a1=1000 a2=1000007 a3=bff16f24 items=0 ppid=1 pid=1070 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0-s0:c0.c1023 key=(null)

Hash: colord,colord_t,colord_t,process,execstack

audit2allow

#============= colord_t ==============
allow colord_t self:process { execstack execmem };

audit2allow -R

#============= colord_t ==============
allow colord_t self:process { execstack execmem };

Comment 1 Daniel Walsh 2011-08-10 17:13:30 UTC
Colord should not need these accesses.

Comment 2 Richard Hughes 2011-08-11 07:37:29 UTC
Indeed, execstack is not required. If you change /etc/colord.conf to have "UseSANE=false", does the denial go away? libsane seems to be pretty insane sometimes.

Comment 3 Jim 2011-08-11 18:49:24 UTC
Yes - I made the change you suggested and the denial went away.  I
shall change back to "true" and wait for the future fix.

Jim Dutton

Comment 4 Richard Hughes 2011-11-15 12:11:41 UTC

*** This bug has been marked as a duplicate of bug 741086 ***


Note You need to log in before you can comment on or make changes to this bug.