Bug 728740 - Constant Logging Of rtl8192c Notice To Console & /var/log/messages
Summary: Constant Logging Of rtl8192c Notice To Console & /var/log/messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 21:25 UTC by RedHat-User
Modified: 2012-01-24 19:58 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.41.10-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-24 07:57:20 UTC


Attachments (Terms of Use)
Patch to move lirmware load message (and do other stuff) (5.83 KB, patch)
2012-01-09 22:35 UTC, Larry Finger
no flags Details | Diff
Dmesg output requested in Comment 8. (68.53 KB, text/plain)
2012-01-10 04:09 UTC, RedHat-User
no flags Details
Backport of Larry's pattch to 3.1.8 (6.03 KB, patch)
2012-01-11 18:44 UTC, Josh Boyer
no flags Details | Diff

Description RedHat-User 2011-08-06 21:25:39 UTC
Description of problem:  After installing the latest kernel on my Lenovo ThinkPad X120e, this notice is now written to the console & /var/log/messages if I am not connected to a wireless network, and every 6 to 8 minutes if I am:

rtl8192c: Loading firmware file rtlwifi/rtl8192cfw.bin

My wireless speed also had dropped.  (Yes, it wasn't spectacular to begin with.)  Transferring a 6.3MB PNG file via SCP:

From wireless laptop running 2.6.40-4 kernel to wired machine:  81.4KB/s
From wired machine to wireless laptop running 2.6.40-4 kernel:  44.1KB/s
From wireless laptop running 2.6.38.8-35 kernel to wired machine:  116.0KB/s
From wired machine to wireless laptop running 2.6.38.8-35 kernel:  68.1KB/s


Version-Release number of selected component (if applicable):  kernel-2.6.40-4.fc15.x86_64


How reproducible:  Install kernel-2.6.40-4.fc15.x86_64.


Steps to Reproduce:
1.  Install kernel-2.6.40-4.fc15.x86_64
2.  Boot into it but do not connect to any wireless network.
3.  Login & tail the /var/log/messages file.
  
Actual results:  See many rtl8192c notices in /var/log/messages.


Expected results:  No rtl8192c notices.


Additional info:

Comment 1 RedHat-User 2011-08-23 15:45:19 UTC
Same thing is happening under kernel-2.6.40.3-0.fc15.x86_64.

Comment 2 RedHat-User 2011-09-12 15:53:38 UTC
Same thing is happening under 2.6.40.4-5.fc15.x86_64.

Comment 3 RedHat-User 2011-10-06 15:16:24 UTC
Same thing is happening under 2.6.40.6-0.fc15.x86_64.

Comment 4 Bill McGonigle 2011-11-02 02:35:29 UTC
This may be a duplicate of bug 729618.

Comment 5 RedHat-User 2012-01-06 02:14:29 UTC
(In reply to comment #4)
===
> This may be a duplicate of bug 729618.
===

At first I thought this wasn't a duplicate since the submitter of that bug was seeing the reload messages while connected to a wireless network and he was experiencing disconnects from the wireless networks.  I do not suffer from either of those problems.

However, then I read comment 84, <https://bugzilla.redhat.com/show_bug.cgi?id=729618#c84>, where a Linux kernel wireless driver maintainer states:
=+=+=+
> The earliest version of the driver had code so that the
> firmware is only reloaded when not actually present. Thus,
> the firmware is NOT being reloaded, no matter what the log
> says.
=+=+=+

Since I only see the message when I am not connected to a wireless network, I suspect this is the case.

It appears a patch to fix this will be in a future Fedora kernel.  (Fedora 17?)  So, I look forward to that release!

Thanks, Bill, for pointing that other Bugzilla ticket out.

Comment 6 Josh Boyer 2012-01-06 15:30:19 UTC
(In reply to comment #5)
> It appears a patch to fix this will be in a future Fedora kernel.  (Fedora 17?)
>  So, I look forward to that release!

I backported the patch mentioned in that specific comment and did a scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3625039

When that finishes building, can you install it and let me know if it gets rid of the messages?

Comment 7 RedHat-User 2012-01-09 20:11:50 UTC
(In reply to comment #6)
===
> I backported the patch mentioned in that specific comment and did a scratch
> build:
===

Thank you for your work.  I downloaded & installed it...


$ sudo rpm -ivh kernel-2.6.41.7-2.5.fc15.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
W: Possible missing firmware "isci/isci_firmware.bin" for kernel module "isci.ko"
W: Possible missing firmware "ct2fw.bin" for kernel module "bfa.ko"
W: Possible missing firmware "ctfw.bin" for kernel module "bfa.ko"
W: Possible missing firmware "cbfw.bin" for kernel module "bfa.ko"
W: Possible missing firmware "aic94xx-seq.fw" for kernel module "aic94xx.ko"


I shutdown the laptop and then booted into that kernel.  However, I still saw this in /var/log/messages approximately every minute:

kernel: [  315.007988] rtl8192c_common: Loading firmware file rtlwifi/rtl8192cfw.bin

Comment 8 Josh Boyer 2012-01-09 20:23:37 UTC
(In reply to comment #7)
> (In reply to comment #6)
> ===
> > I backported the patch mentioned in that specific comment and did a scratch
> > build:
> ===
> 
> Thank you for your work.  I downloaded & installed it...
> 
> 
> $ sudo rpm -ivh kernel-2.6.41.7-2.5.fc15.x86_64.rpm 
> Preparing...                ########################################### [100%]
>    1:kernel                 ########################################### [100%]
> W: Possible missing firmware "isci/isci_firmware.bin" for kernel module
> "isci.ko"
> W: Possible missing firmware "ct2fw.bin" for kernel module "bfa.ko"
> W: Possible missing firmware "ctfw.bin" for kernel module "bfa.ko"
> W: Possible missing firmware "cbfw.bin" for kernel module "bfa.ko"
> W: Possible missing firmware "aic94xx-seq.fw" for kernel module "aic94xx.ko"
> 
> 
> I shutdown the laptop and then booted into that kernel.  However, I still saw
> this in /var/log/messages approximately every minute:
> 
> kernel: [  315.007988] rtl8192c_common: Loading firmware file
> rtlwifi/rtl8192cfw.bin

Just to be sure, can you attach a dmesg from that kernel?

Larry, I backported 8ff08b4318b06eb and applied it to this scratch build.  Was there another commit that was needed to make the messages go away?

Comment 9 Larry Finger 2012-01-09 22:33:06 UTC
Yes. There is one that was originally submitted for V3.2, but it generated a warning and I had to retract it. It mainly fixes a WARNING after suspend/resume for rtl8192cu, but it also moves the firmware loaded message for rtl8192c_common.

I'll upload the patch after I finish this.

The patch will kill the upload message, but the wireless connection is being interrupted every minute, or so. The patch will not fix that, and I have seen no reason given in the logs posted. To see this info, CONFIG_MAC80211_VERBOSE_DEBUG needs to be set in the configuration file.

Comment 10 Larry Finger 2012-01-09 22:35:32 UTC
Created attachment 551689 [details]
Patch to move lirmware load message (and do other stuff)

Comment 11 RedHat-User 2012-01-10 04:09:26 UTC
Created attachment 551755 [details]
Dmesg output requested in Comment 8.

(In reply to comment #8)
===
> Just to be sure, can you attach a dmesg from that kernel?
===

Sure.  Please find it attached as Comment08RequestedDmesg.txt.

Comment 12 Josh Boyer 2012-01-11 16:57:39 UTC
(In reply to comment #10)
> Created attachment 551689 [details]
> Patch to move lirmware load message (and do other stuff)

Which tree is this against?

Comment 13 Larry Finger 2012-01-11 17:07:17 UTC
The patch is for wireless-testing. If it does not apply, what tree would you like?

Comment 14 Josh Boyer 2012-01-11 18:15:07 UTC
(In reply to comment #13)
> The patch is for wireless-testing. If it does not apply, what tree would you
> like?

Oh, I can backport as needed.  I was just curious which tree was your starting point.  I'll backport to 3.1.x and 3.2.x.

Comment 15 Josh Boyer 2012-01-11 18:44:09 UTC
Created attachment 552193 [details]
Backport of Larry's pattch to 3.1.8

Here's a backport of that patch (commit log taken from: http://www.spinics.net/lists/linux-wireless/msg83236.html) to plain 3.1.8.  Larry, does this look right to you?

Comment 16 Larry Finger 2012-01-11 19:19:53 UTC
Yes, that looks OK. In fact, for rtl8192ce, you could keep only the first two hunks. The modification of rtl8192cu/sw.c is to fix a different problem.

Comment 17 Josh Boyer 2012-01-11 19:30:01 UTC
(In reply to comment #16)
> Yes, that looks OK. In fact, for rtl8192ce, you could keep only the first two
> hunks. The modification of rtl8192cu/sw.c is to fix a different problem.

Thanks for the review.  I'll keep both sets of changes since it still fixes a problem people might hit.

I've started a scratch build with the latest patch in it here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3640300

if the original reporter could test that when it's complete, I would appreciate it.

Comment 18 RedHat-User 2012-01-13 03:32:12 UTC
(In reply to comment #17)
===
> if the original reporter could test that when it's complete, I would appreciate
> it.
===

I have tested kernel-2.6.41.8-2.5.fc15.x86_64.rpm.  It worked.  I no longer receive the "rtl8192c_common: Loading firmware file rtlwifi/rtl8192cfw.bin" message in /var/log/messages.  I noticed no problems with my wireless; in fact my SCP transfer speeds appear great:

From wireless laptop to wired machine:  3.0MB/s
From wired machine to wireless laptop:  2.0MB/s

(Please note that I haven't been checking my transfer speeds with each kernel update since when I opened this ticket back in August 2011.  I suspect a previous kernel improved this; I just tried the current 2.6.41.4-1.fc15.x86_64 and got the same speeds.)

Comment 19 Josh Boyer 2012-01-13 18:29:36 UTC
(In reply to comment #18)
> (In reply to comment #17)
> ===
> > if the original reporter could test that when it's complete, I would appreciate
> > it.
> ===
> 
> I have tested kernel-2.6.41.8-2.5.fc15.x86_64.rpm.  It worked.  I no longer
> receive the "rtl8192c_common: Loading firmware file rtlwifi/rtl8192cfw.bin"
> message in /var/log/messages.  I noticed no problems with my wireless; in fact
> my SCP transfer speeds appear great:

Thank you for testing!

I've committed variations of this patch across all three branches.  It should be in the next update for each.

Comment 20 Fedora Update System 2012-01-23 18:32:59 UTC
kernel-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.1-3.fc16

Comment 21 Fedora Update System 2012-01-23 18:36:35 UTC
kernel-2.6.41.10-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.10-3.fc15

Comment 22 Fedora Update System 2012-01-24 01:43:07 UTC
Package kernel-2.6.41.10-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.41.10-3.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0861/kernel-2.6.41.10-3.fc15
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2012-01-24 07:57:20 UTC
kernel-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2012-01-24 19:58:24 UTC
kernel-2.6.41.10-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.