Bug 72877 - Default gw is not updated when dialing ISDN
Default gw is not updated when dialing ISDN
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 13:17 EDT by Inger Karin Haarbye
Modified: 2014-03-16 22:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2002-08-28 13:17:23 EDT
Description of Problem: 
I usually have my default gateway via eth0(192.168.1.1). If I use "neat" to configure and dial 
ISDN-connection, the default gw is changed. That is OK, but when deactivating the ISDN 
connection, default gateway is not back to eth0 (192.168.1.1). 
 
Version-Release number of selected component (if applicable): 
redhat-config-network-1.1.16-1 
 
How Reproducible: 
tried 3 times. 
 
Steps to Reproduce: 
1.  configure isdn connection with neat 
2.  activating the new connection - gw is now set to ippp0/extern IP 
3.  deactivating ippp0 
 
Actual Results: 
Now I don't have a default gw at all. 
 
Expected Results: 
Default gw back to 192.168.1.1 
 
Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-08-28 14:11:03 EDT
Issues like this is handled by initscripts, not rhcn.
Comment 2 Inger Karin Haarbye 2002-10-06 05:39:57 EDT
The problem is still here in Psyche (RedHat 8.0). I usually use a default gw 
on my local network (ADSL). If I want to use my ISDN-connection with neat, the 
default gw is not restored when I deactivate ISDN-connection. I have to add my 
default route manually - or restart network.
Comment 3 Bill Nottingham 2005-09-29 16:16:26 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.