Bug 728776 - error: token "{" is not valid in preprocessor expressions
Summary: error: token "{" is not valid in preprocessor expressions
Keywords:
Status: CLOSED DUPLICATE of bug 714659
Alias: None
Product: Fedora
Classification: Fedora
Component: yajl
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-07 12:08 UTC by Robert Scheck
Modified: 2012-01-30 12:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-30 12:32:34 UTC


Attachments (Terms of Use)
build.log from mock as bzip2 compressed file (2.53 KB, application/bzip2)
2011-08-07 12:10 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2011-08-07 12:08:52 UTC
Description of problem:
Rebuild of i3-4.0.1-1 on Fedora 15 fails while it works on Fedora 16+ and I'm
unable to see another relevant difference than gcc in this case.

Version-Release number of selected component (if applicable):
i3-4.0.1-1.fc15
gcc-4.6.0-10.fc15

How reproducible:
Everytime, try to rebuild i3-4.0.1-1.fcX in mock for x86_64 for example.
  
Actual results:
error: token "{" is not valid in preprocessor expressions

Expected results:
Working rebuild like at Fedora 16+

Comment 1 Robert Scheck 2011-08-07 12:10:47 UTC
Created attachment 517042 [details]
build.log from mock as bzip2 compressed file

Comment 2 Jakub Jelinek 2011-08-18 15:55:21 UTC
rpm -qf /usr/include/yajl/yajl_version.h 
yajl-devel-1.0.11-1.fc15.x86_64
head /usr/include/yajl/yajl_version.h
#ifndef YAJL_VERSION_H_
#define YAJL_VERSION_H_

#include <yajl/yajl_common.h>

#define YAJL_MAJOR ${YAJL_MAJOR}
#define YAJL_MINOR ${YAJL_MINOR}
#define YAJL_MICRO ${YAJL_MICRO}

#define YAJL_VERSION ((YAJL_MAJOR * 10000) + (YAJL_MINOR * 100) + YAJL_MICRO)

Obviously a bug in /usr/include/yajl/yajl_version.h.

Comment 3 Daniel Berrangé 2012-01-30 12:32:34 UTC

*** This bug has been marked as a duplicate of bug 714659 ***


Note You need to log in before you can comment on or make changes to this bug.