Bug 728783 - Some /etc/modprobe.d/*.conf files must be labeled as %config
Summary: Some /etc/modprobe.d/*.conf files must be labeled as %config
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jon Masters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-07 13:09 UTC by Peter Lemenkov
Modified: 2013-03-10 06:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-10 06:52:17 UTC


Attachments (Terms of Use)

Description Peter Lemenkov 2011-08-07 13:09:32 UTC
The following files have notes in comments, advising user to edit them directly:

* depmod-dist.conf
* modprobe-dist-alsa.conf
* modprobe-dist-oss.conf

So these ones are definitely must be marked as %config in %files section.


This file doesn't look to me as intended to be edited by end user, however I'm not so sure. If user may edit it, then it also must be marked as %config

* modprobe-dist.conf

So the %files section should look something like this:

==================================

%files
%defattr(-,root,root)
%dir /etc/modprobe.d
%config(noreplace) /etc/modprobe.d/depmod-dist.conf
%config(noreplace) /etc/modprobe.d/modprobe-dist-alsa.conf
%config(noreplace) /etc/modprobe.d/modprobe-dist-oss.conf
%config(noreplace) /etc/modprobe.d/modprobe-dist.conf
/etc/depmod.d
/sbin/*
%{_mandir}/*/*
%ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/local.conf

==================================

Comment 1 Peter Lemenkov 2013-03-10 06:52:17 UTC
Since this package was retired in favor on kmod I'm going to close this.


Note You need to log in before you can comment on or make changes to this bug.