Bug 72879 - libxslt should provide xsltproc
libxslt should provide xsltproc
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: libxslt (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 13:30 EDT by Joe Shaw
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 13:30:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Shaw 2002-08-28 13:30:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The GNOME2 snapshots ship both libxslt and a xsltproc packages.  In rawhide,
only libxslt is shipped, and /usr/bin/xsltproc is included in it.  To avoid
conflcts, the libxslt rpm should Provide xsltproc, and packages that depend on
it (like oprofile) should depend on xsltproc instead.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Get the gnome 2 snapshots of libxslt but not xsltproc from ftp.gnome.org and
install them.  Then try to build the oprofile package.  It'll die because it
can't find xsltproc.

Additional info:

Once this bug is triaged, another bug against oprofile should be filed which
depends on this bug so that it can depend on xsltproc instead of libxslt as a
build requirement.  Similar checks should be done against all other packages.
Comment 1 Daniel Veillard 2002-08-28 15:16:26 EDT
I disagree with the fact that xsltproc is isolated in a separate
package in the Gnome 2 release, they should fix this, it's their
problem. BTW they could have asked, after all I'm the libxslt 
maintainer of the Gnome project :-(

Daniel
Comment 2 Joe Shaw 2002-08-28 15:29:39 EDT
Turns out I was mistaken and looking at the wrong thing; the gnome 2 snap builds
are only one package, but some internal ximian builds have two, so this is a
non-issue for red hat in terms of package compatibility.  (That's the reason I
filed the bug, after all.  Lots of people have installed the GNOME 2 snapshot RPMs)

I've filed a bug in the Ximian bugzilla about it, I'll reference this bug.

Thanks, sorry bout the trouble.
Comment 3 Daniel Veillard 2002-08-28 15:40:44 EDT
No problem, excellent it was solved that quickly !

Daniel

Note You need to log in before you can comment on or make changes to this bug.