Bug 728845 - crash when delete a device which changed options but not apply
Summary: crash when delete a device which changed options but not apply
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-08-08 06:38 UTC by zhpeng
Modified: 2016-04-26 14:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:15:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
debug info of virt-manager (1.31 KB, text/plain)
2011-08-08 06:38 UTC, zhpeng
no flags Details
full debug info (9.03 KB, text/plain)
2011-09-01 06:16 UTC, zhe peng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description zhpeng 2011-08-08 06:38:39 UTC
Created attachment 517109 [details]
debug info of virt-manager

Description of problem:
when change virtual machine hardware options, but not apply, then remove the hardware,
virt-manager will crash in a minute. 

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6.x86_64
libvirt-0.9.4-1.el6.x86_64
qemu-kvm-0.12.1.2-2.175.el6.x86_64
kernel-2.6.32-175.el6.x86_64

How reproducible:
every time 

Steps to Reproduce:
1.open one virtual machine hardware detail tab(guest os is shutdown)
2.select "Display VNC"
3.change TYEP:"VNC" to TYPE:"SPICE", then apply button is available, but DO NOT CLICK Apply
4.CLICK Remove and press Yes when ask you if you want to remove this device
5.Press Yes when ask you to unsaved apply changes.
  
Actual results:
virt-manager will crash at once or in a minute when you do other operations.


Expected results:
1.not necessary to popup a dialog to warn user save unsaved changes when user removed a device.
2.no crash

Additional info:

Comment 3 Cole Robinson 2011-08-30 19:38:43 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 5 zhe peng 2011-09-01 06:16:15 UTC
Created attachment 520956 [details]
full debug info

test with:
libvirt-0.9.4-6.el6
qemu-kvm-0.12.1.2-2.184.el6
kernel-2.6.32-191.el6
virt-manager-0.9.0-6.el6
python-virtinst-0.600.0-3.el6

step:
launch virt-manager with debug info
#virt-manager --debug
1.open one virtual machine hardware detail tab(guest os is shutdown)
2.select "Display VNC"
3.change TYEP:"VNC" to TYPE:"SPICE", then apply button is available, but DO NOT
CLICK Apply
4.CLICK Remove and press Yes when ask you if you want to remove this device
5.Press Yes when ask you to unsaved apply changes.
in debug info ,have error info like:
/usr/share/virt-manager/virtManager/details.py:1805: GtkWarning: gtk_list_store_get_value: assertion `VALID_ITER (iter, list_store)' failed
  pagetype = row[HW_LIST_COL_TYPE]
/usr/share/virt-manager/virtManager/details.py:1805: Warning: g_value_unset: assertion `G_IS_VALUE (value)' failed
  pagetype = row[HW_LIST_COL_TYPE]
2011-08-31 02:12:25,740 (cli:85): Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1164, in hw_changed
    if self.has_unapplied_changes(oldrow):
  File "/usr/share/virt-manager/virtManager/details.py", line 1154, in has_unapplied_changes
    return not self.config_apply(row=row)
  File "/usr/share/virt-manager/virtManager/details.py", line 1805, in config_apply
    pagetype = row[HW_LIST_COL_TYPE]
SystemError: error return without exception set
None
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1164, in hw_changed
    if self.has_unapplied_changes(oldrow):
  File "/usr/share/virt-manager/virtManager/details.py", line 1154, in has_unapplied_changes
    return not self.config_apply(row=row)
  File "/usr/share/virt-manager/virtManager/details.py", line 1805, in config_apply
    pagetype = row[HW_LIST_COL_TYPE]
SystemError: error return without exception set

full output see attachment
if change to vm graphics console and click hardware detail page again,click item
in left panel will cause crash of virt-manager
the bug not fixed. move to assigned.

Comment 6 Cole Robinson 2011-09-27 00:29:41 UTC
Whoops, upstream fix is correct but I misapplied the patch in the rpm. virt-manager-device-remove-confusion.patch is actually pointing to a different (but needed) fix.

Comment 7 Cole Robinson 2011-10-13 21:49:21 UTC
Fixed in virt-manager-0.9.0-7.el6

Comment 8 Daisy Wu 2011-10-17 03:45:48 UTC
The bug can reproduce on version:
virt-manager-0.9.0-6.el6

Verified on version:
virt-manager-0.9.0-7.el6

Environment:
kernel-2.6.32-206.el6.x86_64
libvirt-0.9.4-17.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.195.el6.x86_64

Detail Steps:
launch virt-manager with debug info
#virt-manager --debug
1.open one virtual machine hardware detail tab(guest os is shutdown)
2.select "Display VNC"
3.change TYEP:"VNC" to TYPE:"SPICE", then apply button is available, but DO NOT
CLICK Apply
4.CLICK Remove and press Yes when ask you if you want to remove this device
5.Press Yes when ask you to unsaved apply changes.
Graphics device removed successfully, virt-manager works well.

2011-10-14 02:51:22,531 (details:2241): Removing device: graphics <virtinst.VirtualGraphics.VirtualGraphics object at 0x37190d0>
2011-10-14 02:51:24,860 (libvirtobject:135): Redefining 'rhel55' with XML diff:
--- Original XML
+++ New XML
@ -40,7 +40,6 @
<target type="serial" port="0"/>
</console>
<input type="mouse" bus="ps2"/>
- <graphics type="vnc" port="-1" autoport="yes" keymap="en-us"/>
<video>
<model type="cirrus" vram="9216" heads="1"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x0"/>

Comment 9 Cole Robinson 2011-10-18 13:02:19 UTC
Hi Daisy, thanks for confirming, can you set bug status to VERIFIED?

Comment 10 min zhan 2011-10-19 01:54:49 UTC
Move to VERIFIED per Comment 8.

Comment 11 Cole Robinson 2011-11-07 16:42:04 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 12 errata-xmlrpc 2011-12-06 16:15:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.