Bug 72885 - LOAD DATA LOCAL not working by default in 7.3
LOAD DATA LOCAL not working by default in 7.3
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-08-28 14:39 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-28 14:39:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-28 14:39:33 EDT
Description of Problem:

Seems from mysql 3.23.49 one must add --enable-local-infile while compiling 
in order for LOAD DATA LOCAL to work by default.  Mysql in RH 7.3 doesn't 
appear to have that in it's SRPM and so LOAD DATA LOCAL doesn't work 
(without presumably setting --local-infile= on client/server.)  I'm mostly 
just curious whether this was intentional or just missed for the 7.3 
packages. It makes upgrading from 7.2 slightly more interesting than 
necessary if this functionality is needed.  Also it doesn't appear
to be mentioned in the release notes for 7.3.

(Again I know this was an upstream change, but Mysql state they
compile with enable-local-infile for their binaries for backwards
compatibility, so I'm mostly just curious whether not being
backwards compat is intentional or not?)

How Reproducible: always

Steps to Reproduce:

Actual Results:

The used command is not allowed with this MySQL version
Comment 1 Trond Eivind Glomsrxd 2002-08-29 12:11:51 EDT
Added in 3.23.52-2

Note You need to log in before you can comment on or make changes to this bug.