Bug 728868 - anaconda could not parse metalink during the net installation
anaconda could not parse metalink during the net installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16Alpha-accepted/F16AlphaFreezeExcept F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-08 04:46 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-16.14.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 18:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log of anaconda 16.14.2 (9.76 KB, text/x-log)
2011-08-08 04:48 EDT, Tao Wu
no flags Details
metalink file (19.65 KB, application/octet-stream)
2011-08-08 04:50 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2011-08-08 04:46:02 EDT
Description of problem:
In the process of install Fedora-16-Alpha-i386-netinst.iso in "Virtual Machine Manager 0.8.7", anaconda could not parse metalink, which would terminate the installation.

Version-Release number of selected component (if applicable):
16.14.2

How reproducible:
always

Steps to Reproduce:
1. Install Fedora-16-Alpha-i386-netinst.iso in kvm like "Virtual Machine Manager 0.8.7"
2. Select the default options 
  
Actual results:
Installation abort when anaconda try to retrieve repository metadata. 

Expected results:
Installation completed successful.

Additional info:
It might be a problem of the default metalink url which was used by anaconda, the url is:
  https://mirrors.fedoraproject.org/metalink?repo=fedora-16-Alpha&arch=i386.

But by the result of accessing this url, we got this message:

  "# repo = fedora-16-Alpha arch = i386 error: invalid repo or arch"

and this:
 
   "
   # following repositories are available:
   ......
   # repo=fedora-16, arch=i386
   ......
   "

so maybe the url should be https://mirrors.fedoraproject.org/metalink?repo=fedora-16&arch=i386 ?
Comment 1 Tao Wu 2011-08-08 04:48:45 EDT
Created attachment 517134 [details]
error log of anaconda 16.14.2
Comment 2 Tao Wu 2011-08-08 04:50:23 EDT
Created attachment 517135 [details]
metalink file
Comment 3 He Rui 2011-08-08 06:39:44 EDT
Yeah, confirmed it. Shouldn't the repo link be fedora-16 instead of fedora-16-Alpha?
Comment 4 James Laska 2011-08-08 09:10:28 EDT
I believe this is the fault of the arguments passed to pungi (or lorax) when composing the installation ISO media.  The version supplied, is expected to be an integer (16).  However, the version supplied is a string (16-Alpha).

I believe we'll need either ...
 1) A change in anaconda to strip out any non-integer elements in that string -- unsustainable patch imo ... string manip always fails
 2) Respin the RC media using an 'integer' --version argument 
 3) Update MirrorManager to recognize the repo=fedora-16-Alpha

Adding dgilmore (rel-eng) since I believe options #2 and #3 fall into his realm.
Comment 5 Dennis Gilmore 2011-08-08 09:25:22 EDT
as a workaround mirrormanager rediects have been put in place, however this really lies in anaconda land, the upgrade check strips off the -Alpha and -Beta  and we should be doing the same here. we need to pass in 16-Alpha and 16-Beta for the version arguments to pungi to ensure that everything is named correctly.
Comment 6 James Laska 2011-08-08 10:44:42 EDT
(In reply to comment #5)
> as a workaround mirrormanager rediects have been put in place, however this
> really lies in anaconda land, the upgrade check strips off the -Alpha and -Beta
>  and we should be doing the same here. we need to pass in 16-Alpha and 16-Beta
> for the version arguments to pungi to ensure that everything is named
> correctly.

I've confirmed the MirrorManager repo=fedora-16-Alpha redirect works.  Will leave this issue open pending anaconda discussion on how to future-proof this defect.
Comment 7 Chris Lumens 2011-08-08 11:04:10 EDT
If this is still reproducible (perhaps not what with the mirrormanager redirect, but maybe someone has a clever idea) can you test with:

updates=http://clumens.fedorapeople.org/728868.img
Comment 8 James Laska 2011-08-08 11:32:07 EDT
(In reply to comment #7)
> If this is still reproducible (perhaps not what with the mirrormanager
> redirect, but maybe someone has a clever idea) can you test with:
> 
> updates=http://clumens.fedorapeople.org/728868.img

Hrmm, yeah, I don't know how to retest this now that MirrorManager is in place.  Maybe dgilmore can temporarily disable the MM changes?
Comment 9 Tim Flink 2011-08-08 12:36:14 EDT
Discussed in the 2011-08-08 Fedora QA meeting. The symptoms have been fixed but the original issue still remains. Accepted as NTH for Fedora 16 Alpha and re-proposed as Fedora 16 Blocker.
Comment 10 Fedora Update System 2011-08-09 00:25:54 EDT
anaconda-16.14.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
Comment 11 Fedora Update System 2011-08-09 02:02:46 EDT
Package anaconda-16.14.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
then log in and leave karma (feedback).
Comment 12 Tao Wu 2011-08-09 02:59:20 EDT
According to the latest test results of anaconda 16.14.3, this problem has been fixed.
Comment 13 Fedora Update System 2011-08-11 11:50:00 EDT
anaconda-16.14.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.4-1.fc16
Comment 14 Fedora Update System 2011-08-15 12:55:46 EDT
anaconda-16.14.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16
Comment 15 Fedora Update System 2011-08-16 16:14:59 EDT
anaconda-16.14.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.6-1.fc16
Comment 16 Fedora Update System 2011-08-18 18:24:30 EDT
anaconda-16.14.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.