Bug 72888 - Failure to remove linuxconf causes catastrophic upgrade failures
Summary: Failure to remove linuxconf causes catastrophic upgrade failures
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-28 19:12 UTC by Ken McDonell
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 22:18:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken McDonell 2002-08-28 19:12:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Upgrade was from RH 6.1 to 7.3.  linuxconf _was_ installed, but since linuxconf
is not included in RH 7.3 and hence not upgraded _but_ linuxconf does depend on
libraries that are removed or moved in the install), _and_ because there are
triggers in the rpm database that still use linuxconf for packages that are
upgraded, the whole upgrade was pretty much a disaster.

The following packages were completely disfunctional after the upgrade, often
with partial installations of the old and the new package: apache, printconf,
sendmail.

If you are withdrawing support for linuxconf (I have no objection to this), then
I believe the upgrade _must_ remove the linuxconf package before it starts.

My only recovery strategy was to:
- remove linuxconf
- rpm -Va
- remove all versions of all damaged packages
- reinstall the damaged packages from the RH 7.3 distribution

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description ... start with RH 6.anything, make sure linuxconf is present,
along with apache, sendmail and some priter spooler, and try an upgrade to RH 7.3

Actual Results:  See description.

Expected Results:  All packages cleanly installed after the upgrade.

Additional info:

Comment 1 Jeremy Katz 2003-01-14 17:46:51 UTC
Added code in CVS to remove linuxconf on upgrade.

Comment 2 Mike McLean 2003-01-21 22:18:12 UTC
confirmed with Phoebe public beta 2 (this fixed another bug as well).


Note You need to log in before you can comment on or make changes to this bug.