Bug 72889 - Anti-aliased text output of fdisk is hard to read
Summary: Anti-aliased text output of fdisk is hard to read
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-28 19:35 UTC by Peter van Egdom
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-14 22:43:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter van Egdom 2002-08-28 19:35:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

Description of problem:

When using fdisk instead of disk-druid as the preferred partitioning tool,
the fonts used for the fdisk output in Anaconda are hard to read.
This is due to the heavy anti-aliasing.

It would be nice if the section of the screen where the output of fdisk is
displayed, is displayed in a non-antialiased font.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 'null'
2. As partitioning tool, select fdisk instead of Disk Druid.
3. Observe that the fonts are hard to read.


Actual Results:  
Fonts are difficult to read, due to the anti-aliasing of the fonts.

Expected Results:  
Fonts should be [terminal-like / non-anti-aliased] for this part of Anaconda.

Additional info:

Comment 1 Michael Fulbright 2002-08-29 16:03:09 UTC
Nalin any ideas to improve this?

Comment 2 Nalin Dahyabhai 2002-08-29 20:13:44 UTC
Try changing the terminal's font from the default using
terminal.set_font_from_string("lucidatypwriter 10")
before showing the widget.  Bitmapped fonts like
lucidatypwriter don't get anti-aliased.

Alternatively, using GtkSettings to adjust the Xft
hinting and antialiasing settings would work, but it
would affect all of Anaconda and not just the terminal
widget.

Comment 3 Peter van Egdom 2002-10-31 19:59:46 UTC
Still happens in Red Hat Linux 8.0.

Comment 4 Michael Lee Yohe 2002-11-09 22:40:14 UTC
This is especially problematic when install Red Hat Linux 8.0 onto a system with
an LCD screen that does auto-stretching from 640x480 to its native mode.

Comment 5 Mike McLean 2002-11-14 22:42:58 UTC
The fdisk pane is white text on a black background which clashes with the rest
of anaconda (dark text on a light background).  Changing the colors might help
the readability.

Comment 6 Michael Fulbright 2002-12-02 19:58:07 UTC
Fdisk is not part of the installer starting with GinGin.

Comment 7 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.