Bug 728946 - [abrt] gnome-tweak-tool-3.0.5-2.fc16: types.py:44:function:NotImplementedError: structure type 'GVariant' is not supported yet
Summary: [abrt] gnome-tweak-tool-3.0.5-2.fc16: types.py:44:function:NotImplementedErro...
Keywords:
Status: CLOSED DUPLICATE of bug 719791
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f06eec25528cd67db0d01368443...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 12:52 UTC by bsfmig
Modified: 2011-08-23 07:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 07:25:18 UTC


Attachments (Terms of Use)

Description bsfmig 2011-08-08 12:52:11 UTC
abrt version: 2.0.5
cmdline:        python /usr/bin/gnome-tweak-tool
comment:        By simpling starting gnome-tweak-tool under Gnome Classic.
event_log:      2011-08-09-08:51:30* (exited with 9)
executable:     /usr/bin/gnome-tweak-tool
kernel:         3.0.0-3.fc16.x86_64
reason:         types.py:44:function:NotImplementedError: structure type 'GVariant' is not supported yet
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Tue Aug  9 08:50:47 2011
uid:            1000
username:       poo

backtrace:
:types.py:44:function:NotImplementedError: structure type 'GVariant' is not supported yet
:
:Traceback (most recent call last):
:  File "/usr/bin/gnome-tweak-tool", line 84, in <module>
:    MainWindow()
:  File "/usr/bin/gnome-tweak-tool", line 47, in __init__
:    model)
:  File "/usr/lib/python2.7/site-packages/gtweak/tweakview.py", line 40, in __init__
:    self._model.load_tweaks()
:  File "/usr/lib/python2.7/site-packages/gtweak/tweakmodel.py", line 103, in load_tweaks
:    mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
:  File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_shell.py", line 207, in <module>
:    GSettingsComboEnumTweak("org.gnome.settings-daemon.plugins.power", "lid-close-battery-action", size_group=sg),
:  File "/usr/lib/python2.7/site-packages/gtweak/widgets.py", line 105, in __init__
:    _type, values = self.settings.get_range(key_name)
:  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 44, in function
:    return info.invoke(*args)
:NotImplementedError: structure type 'GVariant' is not supported yet
:
:Local variables in innermost frame:
:info: <gi.FunctionInfo object (get_range) at 0x0x12dc0d0>
:args: (<GSettingsSetting object at 0x1580fa0 (gtweak+gsettings+GSettingsSetting at 0x165e140)>, 'lid-close-battery-action')

Comment 1 Timon 2011-08-10 05:51:40 UTC
Package: gnome-tweak-tool-3.0.5-2.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
try to run tweak tool

Comment 2 Antonio 2011-08-13 17:21:00 UTC
Package: gnome-tweak-tool-3.0.5-2.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Runnig Gnome-tweak-tool

Comment 3 Jason D. Clinton 2011-08-14 00:42:51 UTC
Package: gnome-tweak-tool-3.0.5-2.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Open program.

Comment 4 DiEOrLivE 2011-08-20 21:50:57 UTC
Package: gnome-tweak-tool-3.0.5-2.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Click to open gnome-tweak-tool

Comment 5 DiEOrLivE 2011-08-21 17:17:52 UTC
Package: gnome-tweak-tool-3.0.5-2.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Open Gnome Tweak Tool.

Comment 6 Michel Alexandre Salim 2011-08-23 07:25:18 UTC

*** This bug has been marked as a duplicate of bug 719791 ***


Note You need to log in before you can comment on or make changes to this bug.