Bug 728969 - SELinux is preventing /usr/sbin/rpc.nfsd from 'module_request' accesses on the system Unknown.
Summary: SELinux is preventing /usr/sbin/rpc.nfsd from 'module_request' accesses on th...
Keywords:
Status: CLOSED DUPLICATE of bug 641836
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: i386
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c0b63ab9105...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 14:14 UTC by Slawomir Czarko
Modified: 2011-08-08 14:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 14:42:51 UTC


Attachments (Terms of Use)

Description Slawomir Czarko 2011-08-08 14:14:54 UTC
SELinux is preventing /usr/sbin/rpc.nfsd from 'module_request' accesses on the system Unknown.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow all domains to have the kernel load modules
Then you must tell SELinux about this by enabling the 'domain_kernel_load_modules' boolean.
Do
setsebool -P domain_kernel_load_modules 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If you believe that rpc.nfsd should be allowed module_request access on the Unknown system by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep rpc.nfsd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:nfsd_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                Unknown [ system ]
Source                        rpc.nfsd
Source Path                   /usr/sbin/rpc.nfsd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nfs-utils-1.2.4-1.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.i686.PAE #1
                              SMP Fri Jul 29 18:47:58 UTC 2011 i686 i686
Alert Count                   6
First Seen                    Mon 08 Aug 2011 04:08:37 PM CEST
Last Seen                     Mon 08 Aug 2011 04:08:37 PM CEST
Local ID                      163ec384-b441-476d-937d-37a6f72cdfd5

Raw Audit Messages
type=AVC msg=audit(1312812517.101:536): avc:  denied  { module_request } for  pid=18939 comm="rpc.mountd" kmod="net-pf-10" scontext=system_u:system_r:nfsd_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=system


type=SYSCALL msg=audit(1312812517.101:536): arch=i386 syscall=socketcall success=no exit=EAFNOSUPPORT a0=1 a1=bfbe7a30 a2=51e16c a3=209bd458 items=0 ppid=18938 pid=18939 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpc.mountd exe=/usr/sbin/rpc.mountd subj=system_u:system_r:nfsd_t:s0 key=(null)

Hash: rpc.nfsd,nfsd_t,kernel_t,system,module_request

audit2allow

#============= nfsd_t ==============
#!!!! This avc can be allowed using the boolean 'domain_kernel_load_modules'

allow nfsd_t kernel_t:system module_request;

audit2allow -R

#============= nfsd_t ==============
#!!!! This avc can be allowed using the boolean 'domain_kernel_load_modules'

allow nfsd_t kernel_t:system module_request;

Comment 1 Daniel Walsh 2011-08-08 14:42:51 UTC

*** This bug has been marked as a duplicate of bug 641836 ***


Note You need to log in before you can comment on or make changes to this bug.