Bug 728978 - Cannot upgrade due to missing obsoletes for git-arch
Summary: Cannot upgrade due to missing obsoletes for git-arch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Todd Zullinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 14:32 UTC by Mamoru TASAKA
Modified: 2013-01-10 10:54 UTC (History)
5 users (show)

Fixed In Version: git-1.7.6-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 14:44:19 UTC


Attachments (Terms of Use)

Description Mamoru TASAKA 2011-08-08 14:32:36 UTC
Description of problem:
]# env LANG=C yum upgrade git
Loaded plugins: downloadonly
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package git.i686 0:1.7.6-3.fc16 will be updated
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-cvs-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-svn-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: emacs-git-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: gitk-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-email-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-arch-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: perl-Git-1.7.6-3.fc16.noarch
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-gui-1.7.6-3.fc16.noarch
---> Package git.i686 0:1.7.6-4.fc16 will be an update
--> Running transaction check
---> Package emacs-git.noarch 0:1.7.6-3.fc16 will be updated
---> Package emacs-git.noarch 0:1.7.6-4.fc16 will be an update
---> Package git.i686 0:1.7.6-3.fc16 will be updated
--> Processing Dependency: git = 1.7.6-3.fc16 for package: git-arch-1.7.6-3.fc16.noarch
---> Package git-cvs.noarch 0:1.7.6-3.fc16 will be updated
---> Package git-cvs.noarch 0:1.7.6-4.fc16 will be an update
---> Package git-email.noarch 0:1.7.6-3.fc16 will be updated
---> Package git-email.noarch 0:1.7.6-4.fc16 will be an update
---> Package git-gui.noarch 0:1.7.6-3.fc16 will be updated
---> Package git-gui.noarch 0:1.7.6-4.fc16 will be an update
---> Package git-svn.noarch 0:1.7.6-3.fc16 will be updated
---> Package git-svn.noarch 0:1.7.6-4.fc16 will be an update
---> Package gitk.noarch 0:1.7.6-3.fc16 will be updated
---> Package gitk.noarch 0:1.7.6-4.fc16 will be an update
---> Package perl-Git.noarch 0:1.7.6-3.fc16 will be updated
---> Package perl-Git.noarch 0:1.7.6-4.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: git-arch-1.7.6-3.fc16.noarch (@fedora)
           Requires: git = 1.7.6-3.fc16
           Removing: git-1.7.6-3.fc16.i686 (@fedora)
               git = 1.7.6-3.fc16
           Updated By: git-1.7.6-4.fc16.i686 (updates-testing)
               git = 1.7.6-4.fc16
           Available: git-1.7.6-1.fc15.i686 (koji-15)
               git = 1.7.6-1.fc15
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

F-15 -> F-16 upgrade path is broken.

Comment 1 Mamoru TASAKA 2011-08-08 14:40:39 UTC
(Note that "F-15 -> F-16 upgrade path is broken" means that F15-updates git-1.7.6-1.fc15 contains git-arch subpackage and F-16 git-1.7.6-4.fc16 does not obsolete this)

Comment 2 Todd Zullinger 2011-08-08 15:24:04 UTC
Yeah, I noticed this only after the update finally was pushed in bodhi (thanks to the autoqa checks).  I'll build another update which includes:

# Obsolete git-arch as needed
%if ! %{arch_support}
Obsoletes:      git-arch <= %{version}-%{release}
%endif

I believe that should do what we want, and allow f15 to continue to ship git-arch and still receive future git version bumps.

Comment 3 Fedora Update System 2011-08-09 16:15:26 UTC
git-1.7.6-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/git-1.7.6-5.fc16

Comment 4 Fedora Update System 2011-08-09 21:53:17 UTC
Package git-1.7.6-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-1.7.6-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/git-1.7.6-5.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-08-22 14:44:09 UTC
git-1.7.6-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.