Bug 728999 - Debug files missing in debuginfo package for 3 binaries
Debug files missing in debuginfo package for 3 binaries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpufrequtils (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Šabata
Rachel Sibley
: EasyFix, Patch
Depends On:
Blocks: 727919 836169
  Show dependency treegraph
 
Reported: 2011-08-08 11:18 EDT by Karel Klíč
Modified: 2014-12-18 04:58 EST (History)
5 users (show)

See Also:
Fixed In Version: cpufrequtils-007-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: Debug options in the package build scripts were disabled. Consequence: No debuginfo packages were generated for cpufrequtils. Fix: Debug options in the build scripts were enabled. Result: Debuginfo should be available for all cpufrequtils binaries.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-18 04:58:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Enable DEBUG (358 bytes, patch)
2011-08-08 11:38 EDT, Petr Šabata
no flags Details | Diff

  None (edit)
Description Karel Klíč 2011-08-08 11:18:54 EDT
A problem related to debuginfo was found in the cpufrequtils-007-5.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/bin/cpufreq-set
  affected package: cpufrequtils-007-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/cpufreq-aperf
  affected package: cpufrequtils-007-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/cpufreq-info
  affected package: cpufrequtils-007-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)
Comment 2 Petr Šabata 2011-08-08 11:38:43 EDT
Created attachment 517245 [details]
Enable DEBUG
Comment 3 RHEL Product and Program Management 2011-08-08 11:40:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 12 Petr Šabata 2014-10-31 10:35:03 EDT
Pushed as cpufrequtils-007-7.el6.
Comment 14 Rachel Sibley 2014-12-04 11:03:32 EST
*************
* Host Info *
*************
# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.6 (Santiago)

#  uname -r
2.6.32-504.el6.i686

# hostname
hp-bl460c-02.rhts.eng.bos.redhat.com

***********
*  Before *
***********

#  rpm -q cpufrequtils
cpufrequtils-007-6.el6.i686

# rpm -q cpufrequtils-debuginfo
cpufrequtils-debuginfo-007-6.el6.i686

#  eu-readelf --notes /usr/bin/cpufreq-set

Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: ce1c2d67e10021af7dc5d911a724bea58afcfb9b


#  eu-readelf --notes /usr/bin/cpufreq-aperf

Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: a0fc711f2faab73c05b1d38a142c25b4d5927d90


# eu-readelf --notes /usr/bin/cpufreq-info

Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: 4e7ab0acbc25315f771bf7f2f501e78c5e65b2d6

# ls -latr *
9c:
total 8
lrwxrwxrwx. 1 root root   28 Dec  4 10:26 1fce7fccc8dc5e284ae45affdf91a392d7c2d3 -> ../../../libcpufreq.so.0.0.0
lrwxrwxrwx. 1 root root   39 Dec  4 10:26 1fce7fccc8dc5e284ae45affdf91a392d7c2d3.debug -> ../../usr/lib/libcpufreq.so.0.0.0.debug
drwxr-xr-x. 2 root root 4096 Dec  4 10:26 .
drwxr-xr-x. 6 root root 4096 Dec  4 10:26 ..

b1:
total 8
lrwxrwxrwx. 1 root root   34 Dec  4 10:26 accde8efd286cd91f7233e166bfccdf71ff3e7 -> ../../../../bin/powernow-k8-decode
lrwxrwxrwx. 1 root root   38 Dec  4 10:26 accde8efd286cd91f7233e166bfccdf71ff3e7.debug -> ../../usr/bin/powernow-k8-decode.debug
drwxr-xr-x. 2 root root 4096 Dec  4 10:26 .
drwxr-xr-x. 6 root root 4096 Dec  4 10:26 ..

c4:
total 8
lrwxrwxrwx. 1 root root   35 Dec  4 10:26 7f1633a7d4b2af45bb2d0f23caee87bed87be8.debug -> ../../usr/bin/centrino-decode.debug
lrwxrwxrwx. 1 root root   31 Dec  4 10:26 7f1633a7d4b2af45bb2d0f23caee87bed87be8 -> ../../../../bin/centrino-decode
drwxr-xr-x. 6 root root 4096 Dec  4 10:26 ..
drwxr-xr-x. 2 root root 4096 Dec  4 10:26 .

c8:
total 8
lrwxrwxrwx. 1 root root   24 Dec  4 10:26 0447c775fe89bd5439f9304cd37d5c9885925d -> ../../../../bin/dump_psb
drwxr-xr-x. 6 root root 4096 Dec  4 10:26 ..
lrwxrwxrwx. 1 root root   28 Dec  4 10:26 0447c775fe89bd5439f9304cd37d5c9885925d.debug -> ../../usr/bin/dump_psb.debug
drwxr-xr-x. 2 root root 4096 Dec  4 10:26 .


*********
* After *
*********

# rpm -q cpufrequtils
cpufrequtils-007-8.el6.i686

# rpm -q cpufrequtils-debuginfo
cpufrequtils-debuginfo-007-8.el6.i686

# eu-readelf --notes /usr/bin/cpufreq-set
Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: 2f400f908a285dd04be8cf1b0ca796c5a7e7e892


# eu-readelf --notes /usr/bin/cpufreq-aperf
Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: ed317301cad6dd70bad1da38a50c8bc30f3ba4c9


# eu-readelf --notes /usr/bin/cpufreq-info
Note section [ 2] '.note.ABI-tag' of 32 bytes at offset 0x148:
  Owner          Data size  Type
  GNU                   16  VERSION
    OS: Linux, ABI: 2.6.18

Note section [ 3] '.note.gnu.build-id' of 36 bytes at offset 0x168:
  Owner          Data size  Type
  GNU                   20  GNU_BUILD_ID
    Build ID: 9b94fe31ff198781d75a80b80f15eb4240c7dd67

# ls -latr /usr/lib/debug/.build-id/*
/usr/lib/debug/.build-id/2c:
total 8
lrwxrwxrwx. 1 root root   28 Dec  4 10:40 561fd1006ad056d40f6510435a4ce3cbbece89.debug -> ../../usr/bin/dump_psb.debug
lrwxrwxrwx. 1 root root   24 Dec  4 10:40 561fd1006ad056d40f6510435a4ce3cbbece89 -> ../../../../bin/dump_psb
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..

/usr/lib/debug/.build-id/2f:
total 8
lrwxrwxrwx. 1 root root   27 Dec  4 10:40 400f908a285dd04be8cf1b0ca796c5a7e7e892 -> ../../../../bin/cpufreq-set
lrwxrwxrwx. 1 root root   31 Dec  4 10:40 400f908a285dd04be8cf1b0ca796c5a7e7e892.debug -> ../../usr/bin/cpufreq-set.debug
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..

/usr/lib/debug/.build-id/9b:
total 8
lrwxrwxrwx. 1 root root   32 Dec  4 10:40 94fe31ff198781d75a80b80f15eb4240c7dd67.debug -> ../../usr/bin/cpufreq-info.debug
lrwxrwxrwx. 1 root root   28 Dec  4 10:40 94fe31ff198781d75a80b80f15eb4240c7dd67 -> ../../../../bin/cpufreq-info
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..

/usr/lib/debug/.build-id/a4:
total 8
lrwxrwxrwx. 1 root root   31 Dec  4 10:40 8e159f746fd988b92d73431b3217816be3a85e -> ../../../../bin/centrino-decode
lrwxrwxrwx. 1 root root   35 Dec  4 10:40 8e159f746fd988b92d73431b3217816be3a85e.debug -> ../../usr/bin/centrino-decode.debug
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..

/usr/lib/debug/.build-id/c7:
total 8
lrwxrwxrwx. 1 root root   39 Dec  4 10:40 4532935a1e79e71f520cfde50db1f9dff0a5af.debug -> ../../usr/lib/libcpufreq.so.0.0.0.debug
lrwxrwxrwx. 1 root root   28 Dec  4 10:40 4532935a1e79e71f520cfde50db1f9dff0a5af -> ../../../libcpufreq.so.0.0.0
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..

/usr/lib/debug/.build-id/cb:
total 8
lrwxrwxrwx. 1 root root   34 Dec  4 10:40 9001df3e47437f80c13487232ed54eb46e3486 -> ../../../../bin/powernow-k8-decode
lrwxrwxrwx. 1 root root   38 Dec  4 10:40 9001df3e47437f80c13487232ed54eb46e3486.debug -> ../../usr/bin/powernow-k8-decode.debug
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .

/usr/lib/debug/.build-id/ed:
total 8
drwxr-xr-x. 9 root root 4096 Dec  4 10:40 ..
lrwxrwxrwx. 1 root root   33 Dec  4 10:40 317301cad6dd70bad1da38a50c8bc30f3ba4c9.debug -> ../../usr/bin/cpufreq-aperf.debug
lrwxrwxrwx. 1 root root   29 Dec  4 10:40 317301cad6dd70bad1da38a50c8bc30f3ba4c9 -> ../../../../bin/cpufreq-aperf
drwxr-xr-x. 2 root root 4096 Dec  4 10:40 .

***********
* Results *
***********
Verified as fixed in in cpufrequtils-007-8.el6.i686/cpufrequtils-debuginfo-007-8.el6.i686, as you can see from the above output the Debuginfo directories exist for '2f' 'ed' '9b' which include a softlink that points to the corresponding binaries.
Comment 16 errata-xmlrpc 2014-12-18 04:58:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-2015.html

Note You need to log in before you can comment on or make changes to this bug.