Bug 729000 - Failed to find the .debug_info section in a debuginfo file
Failed to find the .debug_info section in a debuginfo file
Status: CLOSED DUPLICATE of bug 594279
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils-lib (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:18 EDT by Karel Klíč
Modified: 2014-05-01 17:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-01 17:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:18:57 EDT
A problem related to debuginfo was found in the nfs-utils-lib-1.1.5-3.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

path: /usr/lib/debug/usr/lib/libnfsidmap/umich_ldap.so.debug
package: nfs-utils-lib-debuginfo-1.1.5-3.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)
Comment 5 RHEL Product and Program Management 2012-09-07 01:08:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Steve Dickson 2012-10-12 09:31:11 EDT
I'm not understanding what the problem is here or how to fix it... Can you be a bit more explicit as to what you are asking for?
Comment 7 Karel Klíč 2012-10-15 04:54:47 EDT
Hi Steve,

/usr/lib/debug/usr/lib/libnfsidmap/umich_ldap.so.debug is supposed to contain debugging symbols for umich_ldap.so shared library, but it doesn't contain them.

This is usually caused by a missing compiler/linker flag -g during the package build.

Is nfs-utils-lib build with -g?

Ideally, $RPM_OPT_FLAGS, which includes -g, are added to the compiler flags.
Comment 8 Steve Dickson 2012-10-15 16:51:08 EDT
So something like this:

diff --git a/nfs-utils-lib.spec b/nfs-utils-lib.spec
index fa152a5..7c06576 100644
--- a/nfs-utils-lib.spec
+++ b/nfs-utils-lib.spec
@@ -72,7 +72,8 @@ mv %{librpcsecgss}-%{rpcsecgssvers} %{librpcsecgss}
 
 pushd  %{libnfsidmap}
 ./autogen.sh
-%configure 
+CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS -fno-strict-aliasing`"
+%configure CFLAGS="$CFLAGS"
 make %{?_smp_mflags} all
 popd
Comment 13 Steve Dickson 2014-05-01 17:18:14 EDT

*** This bug has been marked as a duplicate of bug 594279 ***

Note You need to log in before you can comment on or make changes to this bug.