Bug 729002 - Debug files missing in debuginfo package for 14 binaries
Summary: Debug files missing in debuginfo package for 14 binaries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: db4
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Mužila
QA Contact: Jakub Prokes
URL:
Whiteboard:
Depends On:
Blocks: 727919 1359256
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:19 UTC by Karel Klíč
Modified: 2017-03-21 09:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-03-21 09:31:15 UTC


Attachments (Terms of Use)
Specfile edit forcing not to strip debuginfos during 'make install' (516 bytes, patch)
2013-05-16 09:49 UTC, Jan Staněk
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0609 normal SHIPPED_LIVE db4 bug fix update 2017-03-21 12:27:13 UTC

Description Karel Klíč 2011-08-08 15:19:02 UTC
A problem related to debuginfo was found in the db4-4.7.25-16.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/bin/db_load
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_printlog
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_dump185
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_archive
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_recover
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_hotbackup
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/berkeley_db_svc
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_upgrade
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_codegen
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_stat
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_verify
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_checkpoint
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_deadlock
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/db_dump
  affected package: db4-utils-4.7.25-16.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:42:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Jan Staněk 2013-05-16 09:49:34 UTC
Created attachment 748715 [details]
Specfile edit forcing not to strip debuginfos during 'make install'

Comment 5 Jan Staněk 2013-05-16 09:52:02 UTC
Oracle Makefile was stripping debuginfo from binaries during `make install`. Fixed by disabling the strip (by passing /bin/true as the strip command).

Comment 6 RHEL Product and Program Management 2013-10-14 01:01:45 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 13 errata-xmlrpc 2017-03-21 09:31:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0609.html


Note You need to log in before you can comment on or make changes to this bug.