Bug 729003 - Debug files missing in debuginfo package for 7 binaries
Summary: Debug files missing in debuginfo package for 7 binaries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mgetty
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Martin Žember
URL:
Whiteboard:
Depends On:
Blocks: 727919 742210
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:19 UTC by Karel Klíč
Modified: 2015-07-13 04:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: install command was called with -s argument in Makefiles. Consequence: For some binaries shipped in mgetty package there was no debug information in mgetty-debuginfo package Fix: Removed -s from invocations of install command Result: For all binaries shipped in mgetty package there is now debug information in mgetty-debuginfo package.
Clone Of:
: 742210 (view as bug list)
Environment:
Last Closed: 2015-03-23 09:59:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0711 normal SHIPPED_LIVE mgetty bug fix update 2015-03-23 13:59:16 UTC

Description Karel Klíč 2011-08-08 15:19:05 UTC
A problem related to debuginfo was found in the mgetty-1.1.36-8.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/bin/viewfax
  affected package: mgetty-viewfax-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /sbin/mgetty
  affected package: mgetty-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100700
- affected binary: /usr/bin/g3cat
  affected package: mgetty-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/g32pbm
  affected package: mgetty-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/sff2g3
  affected package: mgetty-sendfax-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/pbm2g3
  affected package: mgetty-sendfax-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/sbin/sendfax
  affected package: mgetty-sendfax-1.1.36-8.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:41:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Michal Sekletar 2011-08-12 07:42:26 UTC
Fixed in Fedora -> http://lists.fedoraproject.org/pipermail/scm-commits/2011-August/647069.html

Comment 19 errata-xmlrpc 2015-03-23 09:59:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0711.html


Note You need to log in before you can comment on or make changes to this bug.