Bug 729004 - Debug files missing in debuginfo package for 12 binaries
Debug files missing in debuginfo package for 12 binaries
Status: CLOSED DUPLICATE of bug 693389
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2013-03-03 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 05:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:07 EDT
A problem related to debuginfo was found in the tog-pegasus-2.9.1-5.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/bin/cimmofl-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/bin/cimmof-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/bin/cimprovider-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/bin/wbemexec-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/bin/osinfo-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/repupgrade-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimuser-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimconfig-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimauth-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimsub-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimserver-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750
- affected binary: /usr/sbin/cimprovagt-32
  affected package: tog-pegasus-2.9.1-5.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100750

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)
Comment 2 Vitezslav Crhonek 2011-08-15 05:58:44 EDT
Also note that we have no longer /usr/sbin/*-32 binaries in latest tog-pegasus package.

*** This bug has been marked as a duplicate of bug 693389 ***

Note You need to log in before you can comment on or make changes to this bug.