Bug 729010 - fakeroot debug files missing in debuginfo package for 2 binaries
fakeroot debug files missing in debuginfo package for 2 binaries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fakeroot (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2013-03-03 18:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 08:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:21 EDT
A problem related to debuginfo was found in the fakeroot-1.12.2-22.2.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/lib/libfakeroot/libfakeroot-tcp.so
  affected package: fakeroot-libs-1.12.2-22.2.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/libfakeroot/libfakeroot-sysv.so
  affected package: fakeroot-libs-1.12.2-22.2.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)
Comment 2 Richard W.M. Jones 2011-08-08 11:28:03 EDT
Seems a bit close to 6.2, so I'm going to ask for 6.3 on this one.
Comment 9 RHEL Product and Program Management 2012-07-10 04:08:09 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2012-07-10 19:11:01 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 11 Richard W.M. Jones 2012-08-10 08:48:26 EDT
I'm closing this.  We originally wanted fakeroot and
fakechroot in RHEL to support the old febootstrap (2.x)
code, which we no longer use.

RPM also uses fakeroot, or rather, a very obscure
tool supplied by RPM uses it.  See:
https://bugzilla.redhat.com/show_bug.cgi?id=840779#c4
Also some font tool called 'ttf2pt1'.

Note You need to log in before you can comment on or make changes to this bug.