Bug 729013 - Debug files missing in debuginfo package for 4 binaries
Debug files missing in debuginfo package for 4 binaries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: syslinux (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 727919 756082
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2013-03-03 18:03 EST (History)
4 users (show)

See Also:
Fixed In Version: syslinux-4.02-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:12:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:28 EDT
A problem related to debuginfo was found in the syslinux-4.02-4.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/bin/memdiskfind
  affected package: syslinux-4.02-4.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/isohybrid
  affected package: syslinux-4.02-4.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/syslinux
  affected package: syslinux-4.02-4.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/gethostip
  affected package: syslinux-4.02-4.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)
Comment 5 Alexander Todorov 2012-04-04 06:45:15 EDT
(In reply to comment #0)

> List of binaries without corresponding debuginfo file:
> - affected binary: /usr/bin/memdiskfind
>   affected package: syslinux-4.02-4.el6.i686

# eu-readelf --notes /usr/bin/memdiskfind | grep "Build ID"
    Build ID: ab8528f0fdfa830e9db50e3163c1cfc46aa2d833

# ls -l /usr/lib/debug/.build-id/ab/8528f0fdfa830e9db50e3163c1cfc46aa2d833
lrwxrwxrwx. 1 root root 27  4 апр  6,38 /usr/lib/debug/.build-id/ab/8528f0fdfa830e9db50e3163c1cfc46aa2d833 -> ../../../../bin/memdiskfind


>   binary doesn't contain debug sections (it was probably stripped)
>   affected binary file mode: 100755
> - affected binary: /usr/bin/isohybrid

# eu-readelf --notes /usr/bin/isohybrid | grep "Build ID"
    Build ID: 0afbd367db2921173b41ad5d835583762710ceb5

# ls -l /usr/lib/debug/.build-id/0a/fbd367db2921173b41ad5d835583762710ceb5
lrwxrwxrwx. 1 root root 25  4 апр  6,38 /usr/lib/debug/.build-id/0a/fbd367db2921173b41ad5d835583762710ceb5 -> ../../../../bin/isohybrid



>   affected package: syslinux-4.02-4.el6.i686
>   binary doesn't contain debug sections (it was probably stripped)
>   affected binary file mode: 100755
> - affected binary: /usr/bin/syslinux

# eu-readelf --notes /usr/bin/syslinux | grep "Build ID"
    Build ID: 01959f0e78971c7e0e10102d1e8a521691c71c42

# ls -l /usr/lib/debug/.build-id/01/959f0e78971c7e0e10102d1e8a521691c71c42
lrwxrwxrwx. 1 root root 24  4 апр  6,38 /usr/lib/debug/.build-id/01/959f0e78971c7e0e10102d1e8a521691c71c42 -> ../../../../bin/syslinux


>   affected package: syslinux-4.02-4.el6.i686
>   binary doesn't contain debug sections (it was probably stripped)
>   affected binary file mode: 100755
> - affected binary: /usr/bin/gethostip


# eu-readelf --notes /usr/bin/gethostip | grep "Build ID"
    Build ID: 0e74bde300b33ace8088f6e591fa2e9127a65de8

# ls -l /usr/lib/debug/.build-id/0e/74bde300b33ace8088f6e591fa2e9127a65de8
lrwxrwxrwx. 1 root root 25  4 апр  6,38 /usr/lib/debug/.build-id/0e/74bde300b33ace8088f6e591fa2e9127a65de8 -> ../../../../bin/gethostip


>   affected package: syslinux-4.02-4.el6.i686
>   binary doesn't contain debug sections (it was probably stripped)
>   affected binary file mode: 100755
> 

# rpm -ql syslinux-debuginfo | grep "\.debug"
/usr/lib/debug/.build-id/01/959f0e78971c7e0e10102d1e8a521691c71c42.debug
/usr/lib/debug/.build-id/0a/fbd367db2921173b41ad5d835583762710ceb5.debug
/usr/lib/debug/.build-id/0e/74bde300b33ace8088f6e591fa2e9127a65de8.debug
/usr/lib/debug/.build-id/78/e8ef0e5e5ab1a663cbe6ca2226641c9bb24942.debug
/usr/lib/debug/.build-id/ab/8528f0fdfa830e9db50e3163c1cfc46aa2d833.debug
/usr/lib/debug/sbin/extlinux.debug
/usr/lib/debug/usr/bin/gethostip.debug
/usr/lib/debug/usr/bin/isohybrid.debug
/usr/lib/debug/usr/bin/memdiskfind.debug
/usr/lib/debug/usr/bin/syslinux.debug

syslinux-4.02-6.el6.x86_64
syslinux-debuginfo-4.02-6.el6.x86_64
Comment 6 errata-xmlrpc 2012-06-20 10:12:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0894.html

Note You need to log in before you can comment on or make changes to this bug.