Bug 729014 - Debug files missing in debuginfo package for 13 binaries
Debug files missing in debuginfo package for 13 binaries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: eclipse (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alexander Kurtakov
qe-baseos-tools
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2015-10-08 10:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 10:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:31 EDT
A problem related to debuginfo was found in the eclipse-3.6.1-6.13.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/lib/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.1.R36x_v20100810/eclipse_1309.so
  affected package: eclipse-rcp-3.6.1-6.13.el6.i686
  binary contains debug sections (debuginfo script failed to find/strip it)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-xpcominit-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-xulrunner-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-atk-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-awt-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-cairo-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-gnome-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-glx-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-pi-gtk-3655.so
  affected package: eclipse-swt-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/31/1/.cp/libgnomeproxy-1.0.0.so
  affected package: eclipse-platform-3.6.1-6.13.el6.i686
  binary contains debug sections (debuginfo script failed to find/strip it)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/28/1/.cp/os/linux/x86/libunixfile_1_0_0.so
  affected package: eclipse-platform-3.6.1-6.13.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100644
- affected binary: /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/142/1/.cp/os/linux/x86/libupdate.so
  affected package: eclipse-platform-3.6.1-6.13.el6.i686
  binary contains debug sections (debuginfo script failed to find/strip it)
  affected binary file mode: 100644

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)
Comment 2 RHEL Product and Program Management 2011-08-08 11:41:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Andrew Overholt 2011-08-09 14:47:15 EDT
Is this a regression from the eclipse-3.5.2-5.el6 package?  The upstream build scripts for the native parts (mostly JNI .sos) are hand-rolled so they're likely just missing -g flags.  I could have sworn this was already fixed but I can't find it any logs so I must be dreaming :)
Comment 4 Karel Klíč 2011-08-11 07:30:11 EDT
Andrew, it is not a regression: the eclipse-3.5.2-5.el6 package has the same issue, which is really caused by missing -g flags (build log shows the gcc/g++ calls).

Note You need to log in before you can comment on or make changes to this bug.