Bug 729015 - Failed to find the .debug_info section in a debuginfo file
Summary: Failed to find the .debug_info section in a debuginfo file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iptables
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:19 UTC by Karel Klíč
Modified: 2013-03-03 23:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-13 15:27:55 UTC


Attachments (Terms of Use)

Description Karel Klíč 2011-08-08 15:19:34 UTC
A problem related to debuginfo was found in the iptables-1.4.7-4.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

path: /usr/lib/debug/lib/libiptc.so.0.0.0.debug
package: iptables-debuginfo-1.4.7-4.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:42:25 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Thomas Woerner 2012-09-13 15:27:55 UTC
libiptc can not provide debug informaiton, because there is no code compiled into it. It is an empty library that depends on libip4tc and libip6tc.

The libs libip4tc and libip6tc have debugging symbols.

Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.