Bug 729019 - Failed to find the .debug_info section in debuginfo files
Summary: Failed to find the .debug_info section in debuginfo files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ibutils
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:19 UTC by Karel Klíč
Modified: 2015-01-04 23:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:33:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1639 normal SHIPPED_LIVE RDMA stack bug fix and enhancement update 2011-12-06 00:50:39 UTC

Description Karel Klíč 2011-08-08 15:19:43 UTC
A problem related to debuginfo was found in the ibutils-1.5.4-3.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

- path: /usr/lib/debug/usr/bin/ibnlparse.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibis.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibmsquit.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibdmchk.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/lib/ibdm1.5.4/libibdm.so.1.5.4.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/lib/libibmscli.so.1.0.0.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibdmtr.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibmssh.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibdmsh.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/lib/libibdmcom.so.1.1.1.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/lib/ibis1.5.4/libibis.so.1.5.4.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/bin/ibtopodiff.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686
- path: /usr/lib/debug/usr/lib/libibsysapi.so.1.0.0.debug
  package: ibutils-debuginfo-1.5.4-3.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)

Comment 5 Petr Beňas 2011-08-30 12:47:45 UTC
Reproduced in ibutils-debuginfo-1.5.7-1.el6.x86_64 and verified in ibutils-debuginfo-1.5.7-2.el6.x86_64.

Comment 6 errata-xmlrpc 2011-12-06 15:33:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1639.html


Note You need to log in before you can comment on or make changes to this bug.