Bug 729025 - Debug file missing in debuginfo package for a binary
Summary: Debug file missing in debuginfo package for a binary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: less
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Vojtech Vitek
QA Contact: Petr Šplíchal
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:19 UTC by Karel Klíč
Modified: 2016-06-01 01:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 734827 (view as bug list)
Environment:
Last Closed: 2011-12-06 12:01:43 UTC


Attachments (Terms of Use)
Spec file patch (468 bytes, patch)
2011-08-10 15:03 UTC, Michal Sekletar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1575 normal SHIPPED_LIVE less bug fix and enhancement update 2011-12-06 00:39:01 UTC

Description Karel Klíč 2011-08-08 15:19:58 UTC
A problem related to debuginfo was found in the less-436-4.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

A debuginfo file for a binary is not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

affected binary: /usr/bin/less
affected package: less-436-4.el6.i686
binary doesn't contain debug sections (it was probably stripped)
affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 Michal Sekletar 2011-08-10 15:03:25 UTC
Created attachment 517638 [details]
Spec file patch

Spec file patch removes premature call to strip in order to successfully generate .debug files by find-debuginfo.sh

Comment 8 errata-xmlrpc 2011-12-06 12:01:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1575.html


Note You need to log in before you can comment on or make changes to this bug.