Bug 729027 - Debuginfo package issues in esc
Summary: Debuginfo package issues in esc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: esc
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jack Magne
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:20 UTC by Karel Klíč
Modified: 2015-01-04 23:50 UTC (History)
5 users (show)

Fixed In Version: esc-1.1.0-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 18:00:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1718 normal SHIPPED_LIVE esc bug fix update 2011-12-06 01:02:15 UTC

Description Karel Klíč 2011-08-08 15:20:03 UTC
Several problems related to debuginfo were found in the esc-1.1.0-21.el6 package. These issues might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo missing for binaries
------------------------------
Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/lib/esc-1.1.0/esc
  affected package: esc-1.1.0-21.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/lib/esc-1.1.0/components/librhCoolKey.so
  affected package: esc-1.1.0-21.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/lib/esc-1.1.0/components/librhTray.so
  affected package: esc-1.1.0-21.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

No .debug_info section in a debug file
--------------------------------------
When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

path: /usr/lib/debug/usr/lib/esc-1.1.0/escd.debug
package: esc-debuginfo-1.1.0-21.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)

Comment 2 Jack Magne 2011-08-09 16:43:46 UTC
Looks like this shouldn't be tough to fix, I appear to be doing some stripping of the binaries.

Comment 3 Jack Magne 2011-08-13 21:34:15 UTC
Revised build procedure should ensure that all binaries are debug ready with the exception of the stub executable "esc", which is a stub generated by xulrunner that does nothing but start xulrunner.

Comment 5 Asha Akkiangady 2011-11-04 19:15:14 UTC
The original problem was a required debuginfo missing in the esc build, so verifying this bug as SanityOnly.

On a RHEL-6.2 i386 and X86_64 desktop ESC application (esc-1.1.0-23.el6) installed successfully. Smart card enrollment, format and pin reset operations are successful.

Marking the bug verified.

Comment 6 errata-xmlrpc 2011-12-06 18:00:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1718.html


Note You need to log in before you can comment on or make changes to this bug.