Bug 729028 - Debug file missing in debuginfo package for a binary
Summary: Debug file missing in debuginfo package for a binary
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hspell
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: i18n Engineering List
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:20 UTC by Karel Klíč
Modified: 2014-06-12 12:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 12:46:04 UTC


Attachments (Terms of Use)
spec.patch (557 bytes, patch)
2014-06-12 12:45 UTC, Peter Schiffer
no flags Details | Diff

Description Karel Klíč 2011-08-08 15:20:06 UTC
A problem related to debuginfo was found in the hspell-1.1-3.2.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

A debuginfo file for a binary is not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

affected binary: /usr/bin/hspell
affected package: hspell-1.1-3.2.el6.i686
binary doesn't contain debug sections (it was probably stripped)
affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:41:31 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Dan Kenigsberg 2011-10-16 08:58:00 UTC
Yep, somehow, hspell-1.1-3.2.el6.i686's /usr/lib/libhspell.so.0 has Build ID: 13d6c66c39cfc2ab554c58968bc2e5ee5ede6318, while hspell-debuginfo-1.1-3.2.el6.i686 has something completely different: /usr/lib/debug/.build-id/13/d6c66c39cfc2ab554c58968bc2e5ee5ede6318.debug.

Comment 5 Peter Schiffer 2014-06-12 12:45:17 UTC
Created attachment 908107 [details]
spec.patch

There's a bug in .spec file, see this patch. Anyway, I fixed this problem in Fedora, and I don't think that it's worth fixing in RHEL at this point, so I'm closing this bug as wontfix.


Note You need to log in before you can comment on or make changes to this bug.