Bug 729029 - Debug files missing in debuginfo package for 12 binaries
Summary: Debug files missing in debuginfo package for 12 binaries
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: festival
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:20 UTC by Karel Klíč
Modified: 2017-12-06 10:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 10:37:16 UTC


Attachments (Terms of Use)

Description Karel Klíč 2011-08-08 15:20:09 UTC
A problem related to debuginfo was found in the festival-1.96-18.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /usr/libexec/speech-tools/wfst_build
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/na_play
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/ch_track
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/pitchmark
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/ch_wave
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/wagon
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/wagon_test
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/na_record
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/wfst_run
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/libexec/speech-tools/sig2fv
  affected package: festival-speechtools-utils-1.2.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/festival
  affected package: festival-1.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/festival_client
  affected package: festival-1.96-18.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:42:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Jan Kurik 2017-12-06 10:37:16 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.