Bug 729039 - Failed to find the .debug_info section in debuginfo files
Failed to find the .debug_info section in debuginfo files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gmp (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Jan Kepler
: FastFix
Depends On:
Blocks: 727919 1356056 1430873 1413034
  Show dependency treegraph
 
Reported: 2011-08-08 11:20 EDT by Karel Klíč
Modified: 2017-03-21 06:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: gmp-4.3.1-12.el6
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1413034 (view as bug list)
Environment:
Last Closed: 2017-03-21 06:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:20:41 EDT
A problem related to debuginfo was found in the gmp-4.3.1-7.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

- path: /usr/lib/debug/usr/lib/sse2/libgmpxx.so.4.1.0.debug
  package: gmp-debuginfo-4.3.1-7.el6.i686
- path: /usr/lib/debug/usr/lib/sse2/libgmp.so.3.5.0.debug
  package: gmp-debuginfo-4.3.1-7.el6.i686
- path: /usr/lib/debug/usr/lib/sse2/libmp.so.3.1.14.debug
  package: gmp-debuginfo-4.3.1-7.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)
Comment 2 RHEL Product and Program Management 2011-08-08 11:41:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 errata-xmlrpc 2017-03-21 06:19:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0666.html

Note You need to log in before you can comment on or make changes to this bug.