Bug 729041 - Debuginfo package issues in vim
Debuginfo package issues in vim
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vim (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Karsten Hopp
BaseOS QE - Apps
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:20 EDT by Karel Klíč
Modified: 2013-04-09 09:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 09:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:20:47 EDT
Several problems related to debuginfo were found in the vim-7.2.411-1.6.el6 package. These issues might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo missing for binaries
------------------------------
Debuginfo files for some binaries are not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

List of binaries without corresponding debuginfo file:
- affected binary: /bin/vi
  affected package: vim-minimal-7.2.411-1.6.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755
- affected binary: /usr/bin/xxd
  affected package: vim-common-7.2.411-1.6.el6.i686
  binary doesn't contain debug sections (it was probably stripped)
  affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

Source file missing in debuginfo package
----------------------------------------
Multiple source files that were used by the compiler to generate a binary are missing from the debuginfo package. This is usually caused by the build script creating temporary source files during the build and deleting them after usage, or by moving source files between directories. Missing source files in debuginfo packages make debugging of crashes more difficult.

debuginfo package: vim-debuginfo-7.2.411-1.6.el6.i686
  debuginfo file: /usr/lib/debug/usr/bin/gvim.debug
    missing source: /usr/src/debug/vim72/src/if_perl.c
  debuginfo file: /usr/lib/debug/usr/bin/vim.debug
    missing source: /usr/src/debug/vim72/src/if_perl.c

Please consider changing the package build script (if that is the cause of this issue) to keep the source files on their compilation place, so rpmbuild can find them when generating debuginfo package.

(This bug was detected and filed by a script.)
Comment 2 RHEL Product and Program Management 2011-08-08 11:42:14 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Note You need to log in before you can comment on or make changes to this bug.