Bug 729066 - Pinsetting jobs should be TRACE or FINE, not debug
Pinsetting jobs should be TRACE or FINE, not debug
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Solaris
unspecified Severity low
: ---
: ---
Assigned To: Jesus M. Rodriguez
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-08-08 12:18 EDT by Bryan Kearney
Modified: 2015-05-14 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 09:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
offending catalina.out (10.03 MB, application/x-gzip)
2011-09-13 20:56 EDT, Jesus M. Rodriguez
no flags Details
sample messages (2.99 KB, text/plain)
2011-09-13 20:58 EDT, Jesus M. Rodriguez
no flags Details

  None (edit)
Description Bryan Kearney 2011-08-08 12:18:37 EDT
Hello,

just upgraded to latest stable and getting

DEBUG 
org.fedoraproject.candlepin.pinsetter.core.TransactionalPinsetterJob - 
System

message every five seconds. Would it be possible to issue this rather 
with TRACE or FINEST level than with DEBUG?

I expect this version will fill me HDD soon. :-)

Thanks!
Comment 1 Jesus M. Rodriguez 2011-08-08 12:55:15 EDT
The CancelJob is the one causing this. It runs every 5 seconds. If it weren't for that no one would've noticed this log statement.

I'd be ok with just removing the entire debug statement altogether.
If removed, don't forget to remove the logger statement at the top as well.
Comment 2 Jesus M. Rodriguez 2011-08-08 20:52:49 EDT
Removed debug logging altogether, waiting on patch review.
Comment 3 Jesus M. Rodriguez 2011-08-09 16:06:38 EDT
fixed in 554a988972fa9f4e954bbabcb2bd1ceea8d5fab9
Comment 4 Lukas Zapletal 2011-08-10 03:52:43 EDT
Thanks guys!
Comment 5 Jesus M. Rodriguez 2011-09-13 20:56:03 EDT
Created attachment 523032 [details]
offending catalina.out

attaching a gziped copy of the offending catalina.out containing the offending lines. A separate file containing ONLY the offending lines will be attached as an example.
Comment 6 Jesus M. Rodriguez 2011-09-13 20:58:06 EDT
Created attachment 523033 [details]
sample messages

Here are the offending messages extracted from the previously attached log file for Aug 04 2011. It's clear that it happens every 5 seconds and could easily fill up a log file with useless information.
Comment 7 J.C. Molet 2011-09-27 14:14:45 EDT
Looking at the logs now, it seems to be only logged once, when the tomcat service starts.  This is an acceptable level of logging for this.

Marking VERIFIED.


[root@mgmt5 config]# git branch
  0.2
  0.3
  BETA
* master
  ownergate
[root@mgmt5 config]# git show-ref | grep master
1243076d76a343d157dc49bb0afb2de19ebfc71f refs/heads/master
1243076d76a343d157dc49bb0afb2de19ebfc71f refs/remotes/origin/master

Note You need to log in before you can comment on or make changes to this bug.