Bug 72907 - named logrotate script uses kill instead of rndc
named logrotate script uses kill instead of rndc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 18:47 EDT by Dax Kelson
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 00:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2002-08-28 18:47:15 EDT
Description of Problem: 
 
The file: 
 
/etc/logrotate.d/named 
 
Has this line: 
 
/bin/kill -HUP `cat /var/run/named/named.pid 2> /dev/null` 2> /dev/null 
|| true 
 
This is bad, sending signals to named is deprecated and unreliable. Also, if 
you are running named in a chrooted jail, the PID file will be in a different 
location. 
 
I suggest replacing the line with: 
 
/etc/init.d/named reload 
 
This is clean since you aren't having to maintain the reload code in two 
places.  Alternatively, you can could replace it with (stolen from the sysv 
file): 
 
/usr/sbin/rndc reload >/dev/null 2>&1 || /usr/bin/killall -HUP `/sbin/pidof -o 
%PPID named` || true
Comment 1 Daniel Walsh 2003-01-06 15:01:20 EST
Fixed in bind-9.2.1-12
Comment 2 Dax Kelson 2003-07-03 00:08:44 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.