Bug 72909 - Installer crashed, formatting raid-1
Installer crashed, formatting raid-1
Status: CLOSED DUPLICATE of bug 64734
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-08-28 19:00 EDT by bill
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-29 12:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
I attached the dump file (92.50 KB, text/plain)
2002-08-29 12:14 EDT, Michael Fulbright
no flags Details

  None (edit)
Description bill 2002-08-28 19:00:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
Machine with 10 disks, attempted to install on /dev/sda1 and /dev/sdb1.
Please see URL for the crash dump of anaconda, it specifically instructed me to
send it to redhat.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install redhat-7.3 via nfs to my machine
2.Select NFS install
3.Select installation onto raid-1 containing sda1 and sdb1
4.Screen changes, showing progress, number of packages to go, with a window for
formatting the filesystem, that progress bar gets to 20% or so then dies with a
message saying to get the crash file (above) to redhat.

Actual Results:  A dialog saying write dump to floppy, or boot.

Expected Results:  A happy redhat-7.3 install.

Additional info:

I installed redhat-7.3 on this box before, it may have been from cdrom, alas
it's mounted in a rack, and doesn't have an internal cd drive, so I'm trying a
network install.  I'm quite experiences with linux, been running if for a decade
or so, manage 100 of machines, and have written several linux distributions for
clusters, diskless machines and similar (mostly redhat based).  I.e. it's
nothing simple.
Comment 1 Michael Fulbright 2002-08-29 12:14:49 EDT
Created attachment 73750 [details]
I attached the dump file
Comment 2 bill 2002-08-29 12:30:22 EDT
Here's a raidtab from that machine:
Personalities : [raid0] [raid1] [raid5] 
read_ahead 1024 sectors
md1 : active raid0 sdj2[9] sdi2[8] sdh2[7] sdg2[6] sdf2[5] sde2[4] sdd2[3]
sdc2[2] sdb2[1] sda2[0]
      158239360 blocks 64k chunks
md0 : active raid1 sdb1[1] sda1[0]
      8393856 blocks [2/2] [UU]
unused devices: <none>

As you can see there are 10 drives, and I had 2 partitions each that were
labeled "fd" (raid partition), even though I was only using 2 this would
kill anaconda.  So in EXACTLY the same case when I pulled the other 8
drives (thankfully they were hotswap) the install went just find.  I'm
guessing that either I overflowed an array, or the raid parser can not
deal with drive letters as high as sdj.
Comment 3 Jeremy Katz 2002-08-29 14:21:56 EDT
The update disk available at
http://people.redhat.com/~katzj/73raid.img?  If you put that on a separate
floppy and boot with 'linux updates', inserting the disk when prompted, it
should fix the problem.

*** This bug has been marked as a duplicate of 64734 ***

Note You need to log in before you can comment on or make changes to this bug.