Bug 729129 - Zip file distribution for JCA Adaptor
Summary: Zip file distribution for JCA Adaptor
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-jca
Version: 2.0
Hardware: All
OS: All
high
high
Target Milestone: 2.1.2
: ---
Assignee: Andrew Stitcher
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 19:29 UTC by Irina Boverman
Modified: 2012-12-07 17:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Irina Boverman 2011-08-08 19:29:12 UTC
Description of problem:

JCA Adaptor: Need zip file distribution in addition to RPM for non-Linux users.


Expected results:

Build in brew that will produce a zip file.

Additional info:

Comment 1 Andrew Stitcher 2011-10-06 14:32:14 UTC
As of qpid-java-0.10-11 there is a sub package qpid-java-jca-zip which contains a zipfile for the jca installable.

Comment 2 Jiri Pechanec 2011-10-26 16:32:41 UTC
I tried to compare zip distro with RPMs

Files in zip missing
1) Sources - is there any source zip planned?
2) log4j-slf4j.jar
3) non-JCA exmaples are missing - Is it correct?

I do not like the structure when necessary JAR files are put under examples directory. It may confuse customers that they need not them in the server.

Comment 3 Andrew Stitcher 2011-10-27 16:33:08 UTC
1) I wasn't planning a sources.zip. It would take significant effort as it would need to encompass the qpid JMS code too. 

2) I'm not sure this is required (wouldn't it depend on the slf4j configuration)

3) What non JCA examples? This is explicitly a zip of the JCA work, so it doesn't include anything out side the JCA tree, do you think it needs to?

As far as I know the jar files included in the examples directory are only used by the examples, if anything else needs them it is a bug. The adapter itself has those jars already included in the rar. However if they weren't included for the examples then the examples wouldn't be self contained.

Comment 4 Andrew Stitcher 2011-10-27 16:35:51 UTC
Sorry to not be clear before but could you be explicit about what you think needs to be done here.

Comment 5 Jiri Pechanec 2011-10-31 11:54:38 UTC
Thanks for the answers, I wanted to know that the differences found are there by design, not by omission. I am marking the bug as verified now.


Note You need to log in before you can comment on or make changes to this bug.