Bug 729132 - New alerts lookup failed
New alerts lookup failed
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
4.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon30-bugs rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-08 15:36 EDT by Mike Foley
Modified: 2012-02-07 14:18 EST (History)
4 users (show)

See Also:
Fixed In Version: 4,1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2011-08-08 15:36:58 EDT
Description of problem:  New alerts lookup failed


Version-Release number of selected component (if applicable):


How reproducible:
sporadic

Steps to Reproduce:
1.  i happeed to be looking at reports when this error occured and appeared in the message center
2.
3.
  
Actual results:

sporadic error having to do with alerts

Expected results:

no sporadic errors with alerts 


Additional info:
New Alerts lookup failed
Severity :	
Error
	
Time :	
Monday, August 8, 2011 3:31:21 PM Etc/GMT+4
Detail :	
com.google.gwt.user.client.rpc.InvocationException:
--- STACK TRACE FOLLOWS ---

    at Unknown.java_lang_Throwable_fillInStackTrace__Ljava_lang_Throwable_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_InvocationException_$InvocationException__Lcom_google_gwt_user_client_rpc_InvocationException_2Ljava_lang_String_2Lcom_google_gwt_user_client_rpc_InvocationException_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 1 John Mazzitelli 2011-08-16 16:30:08 EDT
we will get rid of the alerts flag in the main UI and the timer job underneath
Comment 2 Jay Shaughnessy 2011-08-22 17:33:03 EDT
master commit ded5c12883f1d64d57d01f8d8458c99d77956f18

People complained about the alert count widget (the flag at the far left of
the message bar) because it didn't serve much purpose, took up message
real estate, and was refreshed in a background job that would sometimes
generate an exception if server comm was compromised. So, this
commit rips it out.

- also removed the reserved space for the rpc spinner. I think took that
out, so let the message bar expand all the way to the left.
Comment 3 Sunil Kondkar 2011-08-23 08:04:14 EDT
Verified on build#326 (Version: 4.1.0-SNAPSHOT Build Number: 846a462)

The alert flag and count widget is not available in the main UI. The error with alerts in not observed. Marking as verified.
Comment 4 Mike Foley 2012-02-07 14:18:44 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.