Bug 729133 - Kernel panic (divide error) when calling clock_gettime
Summary: Kernel panic (divide error) when calling clock_gettime
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Vivek Goyal
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 19:40 UTC by Charlie Brady
Modified: 2019-09-12 07:40 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 172907
Environment:
Last Closed: 2014-06-02 13:19:57 UTC
charlieb-fedora-bugzilla: needinfo-


Attachments (Terms of Use)
Kernel panic screenshot (185.05 KB, image/png)
2011-08-08 19:40 UTC, Charlie Brady
no flags Details

Description Charlie Brady 2011-08-08 19:40:32 UTC
Created attachment 517292 [details]
Kernel panic screenshot

+++ This bug was initially created as a clone of Bug #172907 +++

Description of problem:
When calling the function clock_gettime() with parameter CLOCK_MONOTONIC, the kernel sometimes crashes, producing the following error

Comment 1 Charlie Brady 2011-08-08 19:44:16 UTC
Problem appears to have been reported against upstream around 2.6.21:

https://lkml.org/lkml/2007/3/2/20

with a simple patch fixed and committed:

http://marc.info/?l=linux-kernel&m=117210430112543&w=2

Was previsouly reported against Fedora 4 (2.6.14-1.1637_FC4), but was assumed to have been fixed (apparently it just became harder to reproduce):

https://bugzilla.redhat.com/show_bug.cgi?id=172907

Comment 2 Vivek Goyal 2011-08-16 13:47:50 UTC
Charlie, How reproducible this problem is for you? How do I reproduce it?

Comment 3 Charlie Brady 2011-08-16 15:08:36 UTC
(In reply to comment #2)

> Charlie, How reproducible this problem is for you? How do I reproduce it?

From our application engineer:

 [our program] calls clock_gettime() every couple of milliseconds and we've 
 seen the bug twice so far this year. Good luck reproducing it.

As you can see in bug 172907, Dave Jones had trouble reproducing it, and therefore thought the problem had been fixed, when in fact it hadn't.

I've tried to reproduce using the program attached to bug 172907 without success. If I find a reproduction scenario I'll let you know.

The patch is simple, has been signed off upstream, and I'm confident it fixes the problem.

Comment 4 RHEL Product and Program Management 2014-03-07 12:50:22 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 5 RHEL Product and Program Management 2014-06-02 13:19:57 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.