Bug 729138 - how to build a storage pool for /dev/mapper?
Summary: how to build a storage pool for /dev/mapper?
Keywords:
Status: CLOSED DUPLICATE of bug 710866
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 19:54 UTC by Marc Haber
Modified: 2011-08-08 20:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 20:00:34 UTC


Attachments (Terms of Use)

Description Marc Haber 2011-08-08 19:54:56 UTC
Hi,

virt-manager seems to handle LVM in the old-fashioned way, accessing the LV devices via /dev/vgname/lvname instead of /dev/mapper/vgname-lvname. This hides other devices which might have been created by device mapper, for example, unlocked crypto devices. I would like to be able to cryptsetup luksOpen /dev/mapper/vgname-c_lvname lvname, which creates a device node /dev/mapper/lvname, and to import the clear text device into an KVM guest.

This does not work since the LVM Volume Group looks into /dev/vgname, not seeing the unlocked device. mpath does obviously only look for /dev/mapper/mpath*, and adding /dev/mapper as a regular directory doesn't work since virt-manager wants do to things with /dev/mapper/control that it cannot do.

The "nice" way would be to add a new storage pool type "Device Mapper", which handles /dev/mapper correctly. A somewhat dirtier way would be  to tell the "directory" storage pool type that /dev/mapper/control needs to be handled differently.

Anyway, I need to find a workaround. Any hints?

Greetings
Marc

Comment 1 Marc Haber 2011-08-08 20:00:34 UTC

*** This bug has been marked as a duplicate of bug 710866 ***


Note You need to log in before you can comment on or make changes to this bug.