Bug 729198 - fix sasl session relocking intead of unlocking it
Summary: fix sasl session relocking intead of unlocking it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 726568 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 02:50 UTC by Daniel Veillard
Modified: 2011-12-06 11:25 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:25:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Daniel Veillard 2011-08-09 02:50:00 UTC
Description of problem: git patch from Guannan Ren <gren@redhat.com>

    When trying to use any SASL authentication for TCP sockets by
    setting auth_tls = "sasl" in libvirtd.conf on server side, the
    client will hang because of the sasl session relocking other than
    dropping the lock when exiting virNetSASLSessionExtKeySize()
    * src/rpc/virnetsaslcontext.c: virNetSASLSessionExtKeySize drop the
      lock on exit


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Veillard 2011-08-09 02:52:30 UTC
Posted and commited upstream:

https://www.redhat.com/archives/libvir-list/2011-August/msg00164.html

8329c56e3a2017399f465aeca06ffa0039e2141a
rpc:fix sasl session relocking intead of unlocking it

Comment 4 Huang Wenlong 2011-08-10 07:42:16 UTC
Verify this bug with : 
libvirt-0.9.4-2.el6.x86_64

in server :

1) set tls_auth=sasl  in libvirtd.conf

2) echo redhat | saslpasswd2 -p -a  libvirt test

3) restart libvirtd 


in client :

# virsh -c qemu+tls://$server_IP/system list
Please enter your authentication name: test
Please enter your password: 
 Id Name                 State
----------------------------------
 16 rr62                 running

Comment 5 Jiri Denemark 2011-08-26 15:06:09 UTC
*** Bug 726568 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2011-12-06 11:25:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.