Bug 729219 - Input/output error occurs when eject /dev/sr0 in the guest
Summary: Input/output error occurs when eject /dev/sr0 in the guest
Keywords:
Status: CLOSED DUPLICATE of bug 614340
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 05:06 UTC by Mike Cao
Modified: 2013-01-10 00:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-12 02:27:37 UTC


Attachments (Terms of Use)
screen dump (71.06 KB, image/png)
2011-08-09 09:21 UTC, Mike Cao
no flags Details

Description Mike Cao 2011-08-09 05:06:17 UTC
Description of problem:
start guest with -drive file=/dev/sr0,media=media ,then click "eject" in the guest ,disk can not be ejected and it prompts "input/output error in the guest 

Version-Release number of selected component (if applicable):
# uname -r&&rpm -q qemu-kvm
2.6.32-171.el6.x86_64
qemu-kvm-0.12.1.2-2.175.el6.x86_64

guest:win08R2

How reproducible:
100%

Steps to Reproduce:
1.intert ubuntu 10.10 AMD 64 bit media in host cdrom
2.start guest with -drive file=/dev/sr0
eg:usr/libexec/qemu-kvm -m 4G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -boot menu=on -drive file=/home/ide-win08R2.raw.test,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none,format=raw -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup,downscript=no,vhost=on -device virtio-net-pci,netdev=hostnet0,mac=76:0E:40:3F:2F:3F -boot dc -uuid dd5aee77-d635-41d4-92a0-4e59c3b5cb6c -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -name win2k8-storage -vnc :10 -drive file=/dev/sr0,if=none,id=drive-ide0-0-2,werror=stop,rerror=stop,cache=none,format=raw,media=cdrom,readonly=on -device ide-drive,drive=drive-ide0-0-2,id=ide0-0-2,bus=ide.0,unit=1
3.in the guest ,right click E:\(which was the cdrom ) ,then click "eject"
  
Actual results:
(qemu) CDROMEJECT: Input/output error
media can not be ejected

Expected results:
media should be ejected successfully.

Additional info:

Comment 1 Markus Armbruster 2011-08-09 09:11:24 UTC
Output of monitor command "info block" before and after the failed eject, please.

Comment 2 Mike Cao 2011-08-09 09:20:12 UTC
(In reply to comment #1)
> Output of monitor command "info block" before and after the failed eject,
> please.

before

(qemu)info block
drive-ide0-0-0: type=hd removable=0 file=/home/ide-win08R2.raw.test ro=0 drv=raw encrypted=0
drive-ide0-0-2: type=cdrom removable=1 locked=0 file=/dev/sr0 ro=1 drv=raw encrypted=0
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]

after:
(qemu) info block
drive-ide0-0-0: type=hd removable=0 file=/home/ide-win08R2.raw.test ro=0 drv=raw encrypted=0
drive-ide0-0-2: type=cdrom removable=1 locked=0 file=/dev/sr0 ro=1 drv=raw encrypted=0
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]

additional info
after click "eject" in the guest ,the media can not be opened ,referring to screendump

Comment 3 Mike Cao 2011-08-09 09:21:52 UTC
Created attachment 517368 [details]
screen dump

Comment 5 Amit Shah 2011-12-07 10:14:12 UTC
Host CDROM passthrough is difficult to get right due to multiple programs involved that need fixing.

Comment 7 Amit Shah 2011-12-09 09:45:44 UTC
This bug looks to be a dup of bug 614340.  To confirm, please check 

https://bugzilla.redhat.com/show_bug.cgi?id=614340#c6

if result is similar to

https://bugzilla.redhat.com/show_bug.cgi?id=614340#c8

we can mark this bug as a dup of that one.

Comment 8 Mike Cao 2011-12-12 02:27:37 UTC
Yes ,from the bug description ,the steps and testing results are same

*** This bug has been marked as a duplicate of bug 614340 ***


Note You need to log in before you can comment on or make changes to this bug.