Bug 729230 - Problems mounting dirs using RHEL6 NFS server
Summary: Problems mounting dirs using RHEL6 NFS server
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 06:53 UTC by David O'Brien
Modified: 2011-08-12 12:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-12 12:11:28 UTC


Attachments (Terms of Use)

Description David O'Brien 2011-08-09 06:53:56 UTC
Description of problem:

Server = RHEL 6 CSB
Client = RHEL 5.7 workstation

with 5.7 set up as the server I could mount dirs on CSB ok.
With CSB as the server I had to jump through all sorts of hoops (ask steved) to get it working.

Mostly I received the following sorts of errors:
failed: RPC Error: Authentication error
mount: mount to NFS server 'daobrien' failed: RPC Error: Program not registered

Trying with nfs4 produced:
mount.nfs4: Permission denied

Firewall on both ends disabled.
SELinux in permissive.

Command used on client:
[root@jupiter ~]# mount -vvv daobrien:/home/daobrien/sandbox/OpenShift /home/david/sandbox/

# cat /etc/exports
/home/daobrien/sandbox/OpenShift *(rw,no_root_squash)

Version-Release number of selected component (if applicable):
Server:
nfs-utils-1.2.3-7.el6.x86_64
nfs-utils-lib-1.1.5-3.el6.x86_64

Client:
nfs-utils-lib-1.0.8-7.6.el5
nfs-utils-1.0.9-54.el5

How reproducible:


Steps to Reproduce:
1. Export a dir on the server
2. Disable both firewalls while setting up/testing
3. Run mount command as described above
  
Actual results:
Error messages as shown above. /var/log/messages also shows messages like:
Aug  9 02:25:30 daobrien rpcbind: connect from 192.168.1.5 to getport/addr(nfs): request from unauthorized host


Expected results:


Additional info:
eventually ran this to get it to work:
pkill rpc.mountd && service nfslock restart && service nfs restart

AND

commented out all lines in /etc/hosts.allow
# ALL:            127.0.0.1       : ALLOW
# sshd:           ALL             : ALLOW
# ALL:            ALL             : DENY

http://fpaste.org/Kwtg/ has rpcinfo -p (for now).

I did try adding nfsd to the allow list but that didn't help.

Comment 2 Steve Dickson 2011-08-12 12:11:28 UTC
It turns out this is not a bug... When I added the following entries
to /etc/hosts.allow

rpcbind:           ALL             : ALLOW
mountd:           ALL             : ALLOW

the mount worked.


Note You need to log in before you can comment on or make changes to this bug.