Bug 729266 - UnboundLocalError: local variable 'device' referenced before assignment
Summary: UnboundLocalError: local variable 'device' referenced before assignment
Keywords:
Status: CLOSED DUPLICATE of bug 681803
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:f57ce18dc97003b38f9c3f0ab7f...
Depends On:
Blocks: 681803 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-09 10:09 UTC by Alexander Todorov
Modified: 2011-08-10 09:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 09:01:08 UTC


Attachments (Terms of Use)
File: anaconda-tb-Dy4cZR (104.62 KB, text/plain)
2011-08-09 10:09 UTC, Alexander Todorov
no flags Details

Description Alexander Todorov 2011-08-09 10:09:06 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-178.el6.x86_64
product:        Red Hat Enterprise Linux
reason:         UnboundLocalError: local variable 'device' referenced before assignment
time:           Tue Aug  9 10:08:22 2011
version:        6.2

anaconda-tb-Dy4cZR: Text file, 107128 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.126 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/kickstart.py", line 618, in execute
:    if devices.has_key(device):
:  File "/usr/lib/anaconda/kickstart.py", line 1230, in execute
:    obj.execute(self.anaconda)
:  File "/usr/bin/anaconda", line 1103, in <module>
:    ksdata.execute()
:UnboundLocalError: local variable 'device' referenced before assignment

Comment 1 Alexander Todorov 2011-08-09 10:09:08 UTC
Created attachment 517374 [details]
File: anaconda-tb-Dy4cZR

Comment 2 Alexander Todorov 2011-08-09 10:11:25 UTC
This bug happened while trying to test bug #6681803


1) Create a virt guest and specify a ks.cfg file for the install.
2) ks.cfg has:
network --device="bootif" --bootproto="dhcp"

Comment 3 Radek Vykydal 2011-08-09 10:45:17 UTC
Alex, I'd mark this one as dupe of the #681803 which just fails QA with the traceback reported here, so that we don't need to hunt for acks etc. I'll post updates.img with fix shortly.

Comment 4 Radek Vykydal 2011-08-09 10:55:47 UTC
This updates image should fix the issue:
http://rvykydal.fedorapeople.org/updates.729266.img

Comment 5 Alexander Todorov 2011-08-10 09:01:08 UTC
Marking as duplicate. Will comment on the other bug.

*** This bug has been marked as a duplicate of bug 681803 ***


Note You need to log in before you can comment on or make changes to this bug.