Bug 72931 - moving windows is VERY slow
moving windows is VERY slow
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-29 03:06 EDT by Andrej Vodopivec
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 13:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Vodopivec 2002-08-29 03:06:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
For somebody used to sawfish moving windows is VERY slow. On an
AMD 2100+ running null/metacity it is way slower than Pentium III/300
running redhat 7.2/sawfish. When window is moved a white shadow is
slowly being changed to background color. Sometimes it even remains
until the pannel is switched.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
???	

Additional info:
Comment 1 Havoc Pennington 2002-08-29 10:21:24 EDT
Seems fine for me and most people. Are you using a remote X connection?
What apps are you moving the window over the top of? Is your X server
accelerated or just using the framebuffer driver?
Comment 2 Richard Torkar 2002-08-29 12:15:57 EDT
Something must be wrong with you settings/hardware.
I find metacity to be much better/faster.

/Richard
Comment 3 Havoc Pennington 2002-08-29 12:23:19 EDT
There was just a mail on the list where someone had gotten 
XaaScreenToScreenCopy (or something like that) option disabled for their G450 
in XF86Config - this might cause massive slowness due to lack of accelerated 
window copying.
Comment 4 Andrej Vodopivec 2002-08-30 04:11:41 EDT
Thank you, this solved my problem. I had a XaaNoScreenToScreenCopy
set in my XF86Config. As I did not mess with X att all I consider this
a bug in installation. Is hp@redhat.com going to file a bug report or should
I do it.
Andrej
Comment 5 Havoc Pennington 2002-08-30 13:14:27 EDT
Thanks, glad it was something simple. We can just move this bug over to X.
Comment 6 Mike A. Harris 2002-09-01 02:00:46 EDT
The G450 XaaNoScreenToScreenCopy is currently off by default in
rawhide.

Note You need to log in before you can comment on or make changes to this bug.